Multiscript reports an erroneous uniqueidentifier

Single-click script execution on multiple SQL Servers.

Multiscript reports an erroneous uniqueidentifier

Postby pbezanson » Wed Dec 10, 2008 8:15 pm

I ran a simple script in Multiscript (version to query the service broker GUID for a database. The script is as follows:

use iAlert

SELECT service_broker_guid
FROM sys.databases
WHERE database_id = DB_ID()

It reported:
(I presume that is: 2BE99620-A189-F646-8C08-C3285C869753)

When I ran the very same script in Query Analyser, it reported:

Does anybody know why Multiscript is reporting a different GUID from Query Analyser?


Posts: 6
Joined: Thu Sep 13, 2007 10:49 pm
Location: Portland, OR USA

Postby dlkj » Mon Dec 15, 2008 10:59 am

Hi Paul,

the value SQL Multi Script is showing is the raw binary representation of the GUID. They are equivalent, but due to a difference in byte ordering, they look different.

I've logged this as a display issue.

Posts: 151
Joined: Tue Aug 14, 2007 4:10 pm
Location: Red Gate Software, Cambridge

Return to SQL Multi Script 1

Who is online

Users browsing this forum: No registered users and 0 guests