"index was outside the bounds of the array" error on undo

Undo for SQL Server.

"index was outside the bounds of the array" error on undo

Postby foxdie » Tue Jan 22, 2008 12:55 pm

Hi all,

Had a SQL injection attack on an old website we host, have patched up the ASP code and tried to undo the changes with SQL Log Rescue but after selecting all the update queries and clicking "Undo operations" it starts to do some processing and then says "index was outside the bounds of the array"..

Thinking that maybe there was too many transactions to process (in the region of 20k) I tried weedling them down to around 3k but I still get the same error.

This problem has happened before but we've only just tracked down how they did it last time, and last time SQL Log Rescue reversed the changes without any problems.

FYI we're using SQL Server 2k and SQL Log Rescue

Kind regards,
Posts: 1
Joined: Tue Jan 22, 2008 12:24 pm
Location: Birmingham, United Kingdom

Return to SQL Log Rescue

Who is online

Users browsing this forum: No registered users and 0 guests