IIS 8 issue with SQL Monitor 3.3

Monitor, diagnose and receive alerts to problems across your SQL Servers.

IIS 8 issue with SQL Monitor 3.3

Postby absnom » Thu Apr 04, 2013 5:33 pm


We have installed a trial version of SQL Monitor 3.3 on a Windows Server 2012 box with SQL Server 2012 and IIS 8. I have followed the instructions for IIS at:

http://www.red-gate.com/supportcenter/C ... M_UsingIIS


http://www.red-gate.com/supportcenter/C ... ASP_issues

However, when I attempt to go the home page of the app, I get a routing error from IIS 8:

HTTP Error 404.0 - Not Found

Detailed Error Information:

Module IIS Web Core

Notification MapRequestHandler

Handler StaticFile

Error Code 0x80070002

Requested URL http://localhost:4444/UrlRouting.axd

Physical Path C:\\Program Files\\Red Gate\\SQL Monitor 3\\WebSite\\UrlRouting.axd

Logon Method Anonymous

Logon User Anonymous

Request Tracing Directory C:\\inetpub\\logs\\FailedReqLogFiles

There is, of course, no UrlRouting.axd. The fact that it is looking for one seems to indicate there is something mis-configured about the routing - but what? Appreciate any insight. Thank you.
Posts: 4
Joined: Thu Apr 04, 2013 5:17 pm

Postby chriskelly » Mon Apr 08, 2013 3:53 pm

Unfortunately configuring IIS is something that we are unable to support you with. This is because IIS is incredibly difficult to debug when the error message are quite vague.

Having said that though, I would recommend that you double check that you have correctly configured the application pool to use integrated mode (Application Pool > Basic Settings).
Chris Kelly
Technical Support Engineer
Posts: 368
Joined: Mon Apr 19, 2010 1:44 pm
Location: Cambridge, UK

Postby absnom » Tue Apr 09, 2013 5:43 pm

Thanks. Understand. Yes, checking that the application pool was set to integrated mode was one of the first things we did.

Fortunately, we managed to get it working yesterday. It turns out that something had changed in our web.config file. We never manually touched it, it was changed via the IIS Manager, as we adjusted settings. However, we kept a copy of the original web.config file and simply replacing the altered config file with the original was sufficient to get it working.
Posts: 4
Joined: Thu Apr 04, 2013 5:17 pm

Return to SQL Monitor Previous Versions

Who is online

Users browsing this forum: No registered users and 0 guests