Having troubles Commiting a user Defined Table

A SQL Server Management Studio add-in to source control your database in Subversion or Team Foundation Server.

Having troubles Commiting a user Defined Table

Postby lkalman@financemgr.com » Tue May 29, 2012 12:54 pm

Issues cant commit User Defined Type Table. It goes thru as it normally does but stills shows as a un commited change

-- User Defined Type

CREATE TYPE [PR].[CalcAppointmentEarning] AS TABLE
[AppointmentEarningID] [int] NOT NULL,
[AppointmentID] [int] NOT NULL,
[EarningID] [int] NOT NULL,
[Entitlement] [decimal] (18, 2) NULL,
[PeriodPay] [decimal] (18, 2) NULL,
[StartDate] [datetime] NULL,
[EndDate] [datetime] NULL,
[IncludeInPeriodPayFlag] [bit] NULL,
[DeletedFlag] [bit] NOT NULL DEFAULT ((0)),
PRIMARY KEY CLUSTERED ([AppointmentEarningID])
-- Permissions

GRANT EXECUTE ON TYPE:: [PR].[CalcAppointmentEarning] TO [AccountingMaster]
Posts: 22
Joined: Wed Apr 11, 2012 1:03 pm

Postby james.billings » Thu May 31, 2012 3:36 pm

Thanks for posting, and sorry you're running into this.

I tested with your script here and it seems to do the same for me, so I've raised a bug (SOC-3955) for it to get looked into. Hopefully we'll get it worked out quickly for you.
Posts: 1122
Joined: Wed Jun 16, 2010 10:10 am
Location: Red Gate

Get the issue as well

Postby harveysburger » Fri Aug 17, 2012 2:44 pm

I am getting the issue as well,

I see this thread is few months old, is there a patch available not for this?

Posts: 6
Joined: Tue Aug 12, 2008 8:12 pm
Location: Netherlands Antilles

Commit changes over and over

Postby mattkarp » Thu Sep 06, 2012 6:06 pm

We have 3 user defined table types that continuously show up as uncommitted over and over. We tried everything in terms of deleting it locally and getting it again form source, changing it locally and on the server but no matter what it continues to show up as 3 uncommitted objects.
Posts: 6
Joined: Mon Nov 01, 2010 6:03 pm

Postby John Palmer » Thu Sep 06, 2012 8:14 pm

I believe this relates to bug SOC-4068

Details in msg 15456:
John Palmer
Posts: 6
Joined: Thu Jun 21, 2012 9:43 pm

Return to SQL Source Control Previous Versions

Who is online

Users browsing this forum: No registered users and 0 guests