Bug: Permissions against schema

A SQL Server Management Studio add-in to source control your database in Subversion or Team Foundation Server.

Bug: Permissions against schema

Postby kbriankelley » Wed Nov 10, 2010 3:53 pm

Following best practice of assigning permission against schema. No changes to schema other than permissions. For instance:

Code: Select all

Commit to TFS failing on Updating local source control information. Information given is:

The list of changes to commit was out of date, so the commit was refused by...
Expected to add 1 files, but only 0 were added.
Posts: 5
Joined: Thu Sep 18, 2008 1:24 pm

Postby Chris Auckland » Thu Nov 11, 2010 6:11 pm

Thanks for your post.

I haven't seen this specific error before, so can I ask exactly what you were doing at the time?

Is this when you're linking a new database to TFS, or are you using an existing repository?

Do you have the necessary permissions to check in and create files in the TFS repository?

Is it only when you're committing these schema permissions changes that you get the issue, or do you have a similar problem committing other objects as well?
Chris Auckland
Posts: 760
Joined: Tue Oct 24, 2006 1:12 pm
Location: Red Gate Software Ltd.

Postby BradLarsen » Tue Dec 14, 2010 2:28 pm

Any updates on this issue? I'm getting the same error message. I'm just trying to commit a small change to a stored procedure... Changing the data type of a parameter from TinyInt to SmallInt.

I don't really understand how the list of changes is out of date. Here's my full process:
1) I went to the GetLatest screen, refreshed, there are no changes.
2) I went to the Commit Changes screen just to be sure, I have no changes pending to commit.
3) I make my edit to the sp.
4) I go to the Source Control window to Commit my Changes. I see a single Edit, with no conflicts.
5) When I try to commit, I get the error, every time.
I have closed SSMS and restarted a couple of times, not really sure where to go next.

Thanks for any suggestions you can provide.
Posts: 1
Joined: Tue Dec 14, 2010 2:23 pm

The list of changes to commit was out of date error solved

Postby mattkarp » Thu Apr 07, 2011 6:45 pm

We got the same, "The list of changes to commit was out of date", error when trying to commit a list of specific objects (table and views). What we discovered is that the list of objects which we were changing were all manually rolled back in TFS the day before. We then went to TFS directly and manually made the changes we were trying to commit via SQL Source Control. We then got latest via SQL Source and made a test comment in one of those objects which we manually checked in via TFS and checked in the test comment via SQL Source no problem. It essentially reset the "state" of those objects on TFS after they had been rolled back.
Posts: 6
Joined: Mon Nov 01, 2010 6:03 pm

Postby chrisherring » Sun Oct 23, 2011 4:21 pm

I am getting this error also: "The list of changes to commit is out of date, so the commit was refused by the server".

I am using GIT. The changed object is a stored procedure. I have tried modifying the SP again (adding a comment), but I still get the same error.

I can commit other changes, but no changes related to this object.
Posts: 4
Joined: Thu Oct 20, 2011 11:49 pm

Postby Brian Donahue » Tue Dec 13, 2011 10:06 am

Hi all,
My interpretation of this message is that the underlying source control system has a conflict that cannot be resolved by SQL Source Control - it's the type of conflict the underlying source control system has its' own methods for dealing with so usually resolving the conflicts in the source control platform itself is the way to go.
Brian Donahue
Posts: 6590
Joined: Mon Aug 23, 2004 9:48 am

Postby reach4thelasers » Tue May 08, 2012 2:16 pm

I am getting this same error with the latest version of SQL SourceControl v3.

My repository is up-to-date and there are no conflicts. I've spent an hour trying to fix this already don't know what else to try
Posts: 3
Joined: Tue May 08, 2012 2:13 pm

Return to SQL Source Control Previous Versions

Who is online

Users browsing this forum: No registered users and 0 guests