Warning 402: Failed to open local data store:

Forum for users of Redgate's SQL Backup tool

Warning 402: Failed to open local data store:

Postby hbuckner » Thu Jul 23, 2009 2:03 pm

I have just installed SQL Backup 6 server components on a 64 bit cluster. Everything installed fine, service is started, and a cluster resource created.

When open the SQLBackup GUI on another machine, and connect to the server I'm getting the following error...

Warning 402: Failed to open local data store: There is a file sharing violation. A different process might be using the file. [\\\\sqlbkup_test\\sqlbkup_test\\vSQLPatriot\\Redgate\\data.sdf]

Any idea where to start trouble shooting?
Posts: 63
Joined: Fri Jun 16, 2006 5:37 pm

Postby Chris.Allen » Fri Jul 24, 2009 4:39 pm

Can you please turn on logging for the service by doing the following :

Open regedit and navigate to the following registry key :


Modify the ImagePath value by appending -sqbdebug to the end of the string.

Now please try restarting the SQL Backup Agent.

A log file should be created in the Server Components Installation directory (%:\\Program Files\\Red Gate\\SQL Backup\\<instance name> by default).

Could you please send me any log files contained there (support@red-gate.com , subject: F0024635)?

If no log is created, please ensure the SQL Backup Agent Service has permissions to write to the folder where it is located.
Posts: 579
Joined: Thu Mar 12, 2009 3:17 pm

Postby SQLDBAsa » Thu Nov 03, 2011 9:07 am

I am having the exact same problem.

What was the resolution?

Posts: 5
Joined: Wed Aug 10, 2011 10:35 am

Postby petey » Fri Nov 04, 2011 6:16 am

Could you please use Process Explorer or Handle (from Sysinternals/Microsoft) to determine which process is locking the data.sdf file on the server?

Peter Yeoh
SQL Backup Consultant Developer
Associate, Yohz Software
Beyond compression - SQL Backup goodies under the hood, updated for version 8
Posts: 2358
Joined: Sun Apr 24, 2005 11:34 am

Postby Croix » Tue May 13, 2014 8:21 pm

I fixed this issue on my server.
For some reason, changing the reg key HKLM\\SYSTEM\\CurrentControlSet\\Services\\SQLBackupAgent by adding the -sqbdebug to the end fixed the problem.
I took the -sqbdebug to the end off the string and it still worked.
Not sure why this fixed it but give it a try.
Posts: 2
Joined: Tue May 13, 2014 8:18 pm
Location: United States

Return to SQL Backup Previous Versions

Who is online

Users browsing this forum: No registered users and 0 guests