Error while launching monitor website after install

Monitor, diagnose and receive alerts to problems across your SQL Servers.

Error while launching monitor website after install

Postby RT01 » Mon Apr 28, 2014 10:03 pm


I installed SQL Monitor web server (XSP) and base monitor successfully. After launching the website, I get the following error when I click the button "Connect to Base Monitor".

"Authentication failed because the remote party has closed the transport stream."

Error in Event Viewer:
2014-04-28 22:05:54,654 [18] ERROR RedGate.Response.Common.Utilities.ThreadPools.ErrorReportingThreadPool [(null)] - Unhandled exception in thread pool
System.ComponentModel.Win32Exception (0x80004005): The credentials supplied to the package were not recognized
at System.Net.SSPIWrapper.AcquireCredentialsHandle(SSPIInterface SecModule, String package, CredentialUse intent, SecureCredential scc)
at System.Net.Security.SecureChannel.AcquireCredentialsHandle(CredentialUse credUsage, SecureCredential& secureCredential)
at System.Net.Security.SecureChannel.AcquireServerCredentials(Byte[]& thumbPrint)
at System.Net.Security.SecureChannel.GenerateToken(Byte[] input, Int32 offset, Int32 count, Byte[]& output)
at System.Net.Security.SecureChannel.NextMessage(Byte[] incoming, Int32 offset, Int32 count)
at System.Net.Security.SslState.StartSendBlob(Byte[] incoming, Int32 count, AsyncProtocolRequest asyncRequest)
at System.Net.Security.SslState.ProcessReceivedBlob(Byte[] buffer, Int32 count, AsyncProtocolRequest asyncRequest)
at System.Net.Security.SslState.StartReadFrame(Byte[] buffer, Int32 readBytes, AsyncProtocolRequest asyncRequest)
at System.Net.Security.SslState.StartReceiveBlob(Byte[] buffer, AsyncProtocolRequest asyncRequest)
at System.Net.Security.SslState.ForceAuthentication(Boolean receiveFirst, Byte[] buffer, AsyncProtocolRequest asyncRequest)
at System.Net.Security.SslState.ProcessAuthentication(LazyAsyncResult lazyResult)
at System.Net.Security.SslStream.AuthenticateAsServer(X509Certificate serverCertificate, Boolean clientCertificateRequired, SslProtocols enabledSslProtocols, Boolean checkCertificateRevocation)
at #1jv.#nkv.#RLv(Stream )
at #1jv.#0jv.#yco(Socket )
at #1jv.#0jv.#A2.#SLv()
at #djJ.#S47.#Pa8(#Q47 )
at #djJ.#S47.#u3.#tWe()
at #djJ.#gjJ.#u3.#tWe(Object )

The host, url, port are all correct.
Checked the services and both web and monitor are running.
Tried using IIS 7.0 and its the same error.
Changed the service account using a domain account with local administrator privilege, but no luck.

Any help is highly appreciated.

Posts: 1
Joined: Mon Apr 28, 2014 9:52 pm

Postby Brian Donahue » Wed Apr 30, 2014 11:49 am

Hi RT,

This happens a lot. The first thing to try is to locate c:\\programdata\\red gate\\sql monitor 4\\Red gate monitor.pfx and delete it. That is the encryption certificate and it should get re-created next time you try to access SQL Monitor.

The next thing is to check if that does not work is the application pool for the app that is running SQL Monitor to ensure the configured identity is an account with sufficient rights to create and use encryption certificate files. Try with SYSTEM and if that works, you can try a lesser-privilege account.

If you need more specific instructions, please let me know. There are a lot of variables in IIS config and I can't describe every possibility without boring everyone tremendously.
Brian Donahue
Posts: 6590
Joined: Mon Aug 23, 2004 9:48 am

Return to SQL Monitor Previous Versions

Who is online

Users browsing this forum: No registered users and 0 guests