How to disable semicolons when comparing

Forum for users of SQL Compare schema synchronization utility

How to disable semicolons when comparing

Postby teasmith » Fri Feb 14, 2014 4:31 pm

Hello

I am doing a comparison between 2 database, and one of the database always have a semicolon between any END and GO commands, while another does not.

this causes more than 300 differences that shouldn't. How do I resolve this? Thanks.

i.e

CREATE TRIGGER [Data].[TR_I_]
ON [Data].[vA]
INSTEAD OF INSERT
AS

BEGIN

//codes

END

;

GO
CREATE TRIGGER [Data].[TR_U]
INSTEAD OF UPDATE
AS

BEGIN

//codes

END

;
teasmith
 
Posts: 1
Joined: Fri Feb 14, 2014 4:26 pm

Postby Brian Donahue » Mon Feb 17, 2014 12:44 pm

Hello,

There currently is no option to ignore semicolons, such as there is to ignore white space. Please feel free to request this as a feature here:

http://redgate.uservoice.com/forums/141379-sql-compare
Brian Donahue
 
Posts: 6590
Joined: Mon Aug 23, 2004 10:48 am


Return to SQL Compare Previous Versions

Who is online

Users browsing this forum: No registered users and 2 guests

cron