SQL Prompt insert TAB,Space, Enter ????

Provides intelligent code completion for SQL Server editors.

SQL Prompt insert TAB,Space, Enter ????

Postby mario17 » Fri Jan 17, 2014 2:46 am


I see that Enter is working different when I select from menu, it insert column name from list + rightmost characters of this name from the current position

To reproduce:
1. start select... from your_table
2. start typing column name let say 'ben..'
3. menu pop ups with available choices

4. Down error select on benefit_name
..see benefit_name inserted on edit screen
..list change a look

** now I know just get way from SQL Prompt

6. ENTER (again)
.. <benefit_nameefit_name> that what I have now????!!!!!!

#6 could be replicated also with TAB as well.

On my option I have in SUggetsion/BEhavior/Insertion Keys
Enter checked ON
TAB checked ON
Space bar ... nothing (OFF)

Is that normal? What I'm missing?????

Posts: 9
Joined: Wed Jan 15, 2014 5:08 pm
Location: United States

Postby Aaron Law » Fri Jan 17, 2014 2:34 pm

Hi Mario,

It sounds like you've got the built in intellisense as well as Prompt enabled. You can disable the built in intellisense popping up by going to Tools->Options->Text Editor->Transact-SQL and unticking Auto list members and Parameter information.

Another user has reported the same issue so I think our installer might not be disabling it in all cases. Can I ask which version of SSMS you are currently running?

Aaron Law
Posts: 597
Joined: Fri Jun 28, 2013 9:56 am
Location: Red Gate Software

Intellisense insertion

Postby SullivaR » Fri Jan 17, 2014 8:37 pm

Hi Mario,

I searched the forums because i had a similar issue. I found the problem for me under SQL Prompt - Options -> Suggestions > Behavior > Insertion keys section. I had nothing checked for the insertion trigger here. In this section, one can select which key to press to trigger the insertion from the Suggestion dropdown. Once i checked the key press to use (i chose Space bar) then the insertion action worked. Hope this helps.

Kind regards,
Randy Sullivan
Posts: 2
Joined: Thu Jan 09, 2014 8:54 pm

Intellisense insertion

Postby budnar » Fri Jan 24, 2014 7:55 pm

To answer and add to Aaron's post, I did notices the same behaviour as the one he answered to and I aplied his fix... it worked but I had to restart SSMS.

My version of SSMS is 10.50.1600.1 and Prompt SQL is

Hope it helps,
Posts: 1
Joined: Fri Jan 24, 2014 6:52 pm

Return to SQL Prompt

Who is online

Users browsing this forum: No registered users and 1 guest