Can't Pinpoint Cause of CPU Usage (Silverlight)

Code profiling for .NET developers.

Can't Pinpoint Cause of CPU Usage (Silverlight)

Postby BSayatovic » Tue Nov 12, 2013 3:56 pm

I'm using ANTS Performance Profiler 8.3 to try and track down the source of a CPU usage problem in my Silverlight application. After a couple of hours of usage, the CPU usage settles at 50% (on a dual-core computer; 25% on a quad-core, etc.) even when the application is effectively idle.

Here's a timeline:

During the first "idle" period, CPU usage is effectively 0%. During the last "idle" period, CPU usage is at 50%. I've compared the "hot spots" in call tree, and method grid and the hit counts, CPU ticks, etc. of the methods at each point are basically the same. It seems as though nothing *within* my application is what's using the CPU.

Can anyone confirm that it is possible to see CPU usage in the timeline of 50% (which I believe is measured by the Windows Performance Counter for the process) while ANTS Performance Profiler's own instrumentation doesn't actually catch the culprit?
Posts: 2
Joined: Tue Nov 12, 2013 3:50 pm

Postby Chris.Allen » Thu Nov 14, 2013 12:25 pm

I'm sorry but its very hard to know what the actual question is and, further, what the data you are using is- would you mind sending your results in to us at please? I'm sure all will be a lot clearer then. :)
Posts: 579
Joined: Thu Mar 12, 2009 3:17 pm


Postby BSayatovic » Mon Nov 18, 2013 7:04 pm

I somehow missed your forum reply until now. I've just e-mailed support directly.
Posts: 2
Joined: Tue Nov 12, 2013 3:50 pm

Return to ANTS Performance Profiler 8

Who is online

Users browsing this forum: No registered users and 1 guest