Bug: Table disappear from the object explorer

A SQL Server Management Studio add-in to source control your database in Subversion or Team Foundation Server.

Bug: Table disappear from the object explorer

Postby vbogoly » Fri Jun 14, 2013 8:34 pm

After I made changes in table structure using table designer, table name disappear from the object explorer.

SQL Source Control 3.2.027
SSMS 10.50.2500

Thank you
Posts: 3
Joined: Thu May 06, 2010 12:58 am

Same problem, pending changes are disappearing

Postby jrohatec » Sat Jun 15, 2013 12:09 am


Here is the brief summary of my settings.

OS: windows 2008R2
SQL: Microsoft SQL 2008
SQL Source Control Installed:
SVN: TortoiseSVN 1.7.10

I have a batch file to deploy two different databases and both databases are linked in the shared database development mode. Here is what I have been experienced.

1. First run, there wasn't way detection after the deployment. No blue dots showing on object explorer. Only two green icons are showing for the linked databases and these databases are linked to SVN repository.

2. I tab back and forward between "Setup" and "Commit changes" under SQL Source Control. Then it finds out the pending changes on the first databases as blue dots in tables and stored procedures. Even tough my SQL batch contains the changes of the schema and data for both databases, it picked up and showed blue dots only in the first database. I was able to make the first check in into the first database. but there is no sign or blue dots on the second databases at all.

3. I reboot the server and tried to deploy from the batch file. Now, both databases are showing changes in blue dots. So, I clicked "Commit Changes" tab. Then, all the blue dots are disappeared all of suddent. Never coming back. even though I restarted SSMS or refresh.
Then, I did the same attempt to the 2nd databases to check in and those blue dots are gone again after tab to "Commit Changes".

any ideas????
Posts: 1
Joined: Fri Jun 14, 2013 11:55 pm

Return to SQL Source Control 3

Who is online

Users browsing this forum: No registered users and 0 guests