microsoft.Visualbasic.powerpacks error in

A SQL Server Management Studio add-in to source control your database in Subversion or Team Foundation Server.

microsoft.Visualbasic.powerpacks error in

Postby wtjones » Wed Feb 20, 2013 11:04 pm

I just upgraded to from a fresh install and I get this when I try to 'edit comparison options'

Could not load file or assembly 'Microsoft.VisualBasic.PowerPacks.Vs, Version=, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' or one of its dependencies. The system cannot find the file specified.

I installed the vb powerpack 3 but it did not fix the issue.
Posts: 14
Joined: Tue Jan 08, 2008 3:27 pm

Postby wtjones » Thu Feb 21, 2013 1:48 pm

I was able to work around this by copying Microsoft.VisualBasic.PowerPacks.Vs.dll to the Redgate folder.

I obtained this from my VS 2010 installation at C:\\Program Files (x86)\\Reference Assemblies\\Microsoft\\VBPowerPacks\\v10.0\\Microsoft.VisualBasic.PowerPacks.Vs.dll

Redgate may want to bundle this into the installer :wink:
Posts: 14
Joined: Tue Jan 08, 2008 3:27 pm

Microsoft.VisualBasic.PowerPacks.Vs.dll still not found

Postby David A » Fri Apr 05, 2013 7:53 pm

I installed VisualBasic Power Pack 3.5 from this URL: ... x?id=25169

On my 64-bit machine, it installed it here: C:\\Program Files (x86)\\Microsoft Visual Basic 2005 Power Packs\\3.0

I copied the file to: C:\\Program Files (x86)\\Red Gate\\SQL Source Control 3

Did not work in SSMS. Without removing the above copy, also copied it to: C:\\Program Files (x86)\\Red Gate\\SQL Data Compare 10

Still did not work. I suppose I should also mention I shutdown SSMS each time. There was also a companion XML file which I also tried copying.

David A
Posts: 8
Joined: Mon Apr 21, 2008 4:48 pm

v10 is 3.5

Postby antiRev » Wed May 01, 2013 3:53 pm

The link supplied above is for version 3, it needs to be v3.5 which internally is v10, v3.0 is 9
Posts: 2
Joined: Thu Dec 06, 2012 10:50 am
Location: United Kingdom

Postby sgilboy » Thu May 09, 2013 8:15 pm

here is how I got around this error.... it was made difficult because the target machine doesn't have Studio installed meaning that the gacutil.exe wasn't installed either:

- Copied "Microsoft.VisualBasic.PowerPacks.Vs.dll" from my development machine to our development SQL server (Windows 2008 R2).. it's in C:\\Temp

- open a command prompt as "Run as Administrator"

- C:>explorer C:\\Windows\\assembly

- that will open an explorer window there

- go back to the command prompt and now type:

- C:>explorer C:\\Temp

- that will open a second window

- drag the DLL from the second explorer window to the first and the DLL will be in the GAC !

Works !!

If you try to navigate around in the first explorer window you will "lose" your permissions, so just open two.... gotta love Windows....
Posts: 31
Joined: Wed Jun 22, 2011 6:38 pm

Return to SQL Source Control Previous Versions

Who is online

Users browsing this forum: No registered users and 0 guests