Problem with connection to SQL instance in cluster

Monitor, diagnose and receive alerts to problems across your SQL Servers.

Problem with connection to SQL instance in cluster

Postby JoeGT » Tue Nov 20, 2012 7:29 am

Bit of background before I give the details.

We run a 5 node SQL 2008 R2 failover cluster. I have had SQL Monitor (v working fine on all of the hosts and instances in this cluster until the weekend just gone (Nov 17th).

During this weekend in a maintenance window we had to replace a faulty multi port NIC card in one of the servers.

Monitoring logs in the SQL Monitor UI show that records stopped being collected for the instance hosted on this server from the point the server was taken offline for this maintenance work.

However in the "Manage Monitored Servers" area the Host and this instance were both still showed as a good status of "Monitoring Connected". A quick look however confirmed that while the data for the host was still collecting and all of the performance stats for CPU, memory, disk etc were still updating, the SQL instance was showing no new data.

I have tried several things to resolve this.

*Attempted the "Retry Connection" option - nothing happened here and I assume this is because the Retry Connection option is only valid if the app thinks there is a problem with the connection.
Failed the instance to another node in the cluster - I did this in case it was a problem with the instance being hosted on the node with the changed NIC card. This made no difference

*Removed the instance from monitoring and re-added it - at this point the status changed to "Unreachable Cannot Connect" (tried this several times using combantions of IP\\instance hostname\\instance etc etc)

The error displayed in the connection Log is :

Date 20 Nov 2012 7:19 AM

Group SQL

Event GetVersion

Outcome Cannot connect

Exception SqlException

Exception message

A network-related or instance-specific error occurred while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections. (provider: Named Pipes Provider, error: 40 - Could not open a connection to SQL Server)

This issue here is that the account being used to connect is the same as is being used for all of the other instances and nothing has changed on this front. So should be able to rule out a logon issue. The instance is definitely online and is accessible via :

red Gate SQL Backup Pro
.Net (through our web application)

So I guess I am looking for clues as to where to go from here.

Appreciate any help.


Posts: 47
Joined: Wed Jun 13, 2012 2:37 am

Postby JoeGT » Tue Nov 20, 2012 8:11 am

Just an addition to this. I now seem to have a similar issue with another of my servers in another of our 5 nodes clusters (a different one from the one above).

The version of SQL Monitor is the same and the issue this time is that the monitoring status is apparently OK (for both the HOST and the instance) however there are no new alerts being generated (for either) nor are any of the performance metrics being gathered or displayed.

This is seeming a little more like it might actually be a product fault at this point. Def interested in any feedback.


Posts: 47
Joined: Wed Jun 13, 2012 2:37 am

Postby Brian Donahue » Wed Nov 21, 2012 4:43 pm

I'm sorry you have encountered this issue. I will be responding to you via email with the information relevant to troubleshooting this problem.

Brian Donahue
Posts: 6590
Joined: Mon Aug 23, 2004 9:48 am

Postby JoeGT » Wed Nov 21, 2012 11:21 pm

Thanks Brian. Have replied back with some of my findings (one of the issues is resolved now). Look forward to hearing back from you.


Posts: 47
Joined: Wed Jun 13, 2012 2:37 am

Postby JoonaHook » Thu Dec 20, 2012 10:40 am

I have exactly same problem. It would be nice if you could at least post if this problem was resolved or not..

I have opened new support request for this.
We have two node active/active cluster and I can't see the instances in overview and analysis sql data is empty.

Joona Hook
Posts: 9
Joined: Wed Nov 09, 2011 8:50 am

Postby JoeGT » Thu Dec 20, 2012 8:03 pm

This issue resolved itself. I was able to remove the instances I was having an issue with and re-add them and now monitoring is working correctly.

There is a possibility that the issue was still related to either NIC configuration or SNMP problems I was experiencing on both of these servers. Cant be more specific than that unfortunately.
Posts: 47
Joined: Wed Jun 13, 2012 2:37 am

Postby JoeGT » Thu Dec 20, 2012 9:49 pm

Hmm... Typical. I say that it is resolved and then dig a little deeper only to find that I still have the issue on one of the host machines.

The problem here is that the "Manage Monitored Servers" page shows that the status for this host is :

Monitoring Connected

However looking at the "Overviews" screen for this host, the host shows no alerts and the sparkline graphs for Processor and Memory are not updating.


Also on the overview page for this host, none of the metrics are showing any values

System processes (top 10)


I have tried the following to resolve this :

* Removed the cluster from monitoring and re-added
* Changed the account being used for the Base Monitor
Posts: 47
Joined: Wed Jun 13, 2012 2:37 am

Postby chriskelly » Mon Jan 07, 2013 1:40 pm

Hi JoeGT

If you are still suffering from this latest issue, please can you reply to Brian's last email with these details and any SQL Monitor log files and we will investigate further. ... M_LogFiles
Posts: 373
Joined: Mon Apr 19, 2010 12:44 pm
Location: Cambridge, UK

Return to SQL Monitor Previous Versions

Who is online

Users browsing this forum: No registered users and 0 guests