Error: Invalid numeric precision/scale on data compare

Compares and synchronizes SQL database content.

Error: Invalid numeric precision/scale on data compare

Postby stefan.r » Fri Jul 13, 2012 1:49 pm

I'm using the following command to sync a database to a scripts folder :
- sqldatacompare.exe /s1:Computer /db1:DB /makescripts:"c:\\Scripts" /verbose /sync
This works fine.But when I try a compare of the DB database to the scripts generated previously I get the following error : invalid numeric precision/scale
This is the compare command:
- sqldatacompare.exe /s1:Computer /db1:DB /scripts2:"c:\\Scripts" /verbose
I've also tried from the GUI to create a project but the same error appears.Please note that this is run on a controlled environment and no changes are made to the DB database.Also when comparing the scripts with the database (switch the source and destination) I get no errors and it works as expected(no differences). Also please note that most of the tables that give the error (I didn't check them all) have columns that are defined as custom types.
Posts: 1
Joined: Fri Jul 13, 2012 1:22 pm

Return to SQL Data Compare Previous Versions

Who is online

Users browsing this forum: No registered users and 0 guests