Does SQL Prompt 4 work with SSMS 2012?

Provides intelligent code completion for SQL Server editors.

Does SQL Prompt 4 work with SSMS 2012?

Postby AndrewBA » Wed Jun 20, 2012 4:36 am


I have recently installed SQL Server 2012 on my machine, however the SQL Prompt 4 menu is not in the SSMS 2012 menu bar. I have uninstalled and re-installed SQL Prompt 4 but it still only appears in SSMS 2008.

SQL Prompt 5.3 does appear in both versions of SSMS but unfortunately I don't have a licence for this version!

Does anyone know how to get SQL Prompt 4 working with SSMS 2008?

Any suggestions will be gratefully received.

Posts: 12
Joined: Tue Oct 27, 2009 6:08 am
Location: West Perth

Postby peter.peart » Thu Jun 21, 2012 12:51 pm

Thanks for your post. SQL Prompt 4 isn't compatible with 2012 so you're not going to get it integrated within SSMS 2012.

You are going to need to upgrade your existing license, which the sales team will be more than happy to assist with. It will be cheaper for you than purchasing a new license outright.

If you want to upgrade, please just send an e-mail to and we'll be happy to help.

Peter Peart
Red Gate Software Ltd
+44 (0)870 160 0037 ext. 8569
1 866 RED GATE ext. 8569
Site Admin
Posts: 362
Joined: Tue Sep 02, 2008 8:58 am
Location: Top floor, RG towers with the cool kids

Return to SQL Prompt Previous Versions

Who is online

Users browsing this forum: No registered users and 1 guest