Script file does not resolve difference when ran

Automate and integrate using the SQL comparison API

Script file does not resolve difference when ran

Postby SQLAdminCJ » Fri May 18, 2012 10:20 pm

Hey all,

I am using SQL Data Compare SDK to attempt to synchronize 2 databases. In one table, there is a row where an nvarchar field is off by one carriage return. So, for example, if the field in one database is:

"This is a test field.[CRLF]

The field in the other database is:

"This is a test field.[CRLF]

The [CRLF] is a stand-in for the formatting characters \\r\\n.

When I run the utility I've written, it generates a query to make the shorter field (i.e. the one with one CRLF) to be like the longer field. This generates and I run it on the intended database, but then when I run the utility again, the row is still shorter by one CRLF. This is frustrating. Does anyone know how I can go about addressing this? I would appreciate any help that anyone can give.
Posts: 10
Joined: Wed Dec 28, 2011 1:03 am

Postby Brian Donahue » Mon May 21, 2012 3:24 pm

If you are using the SDK to create the migration script, the best suggestion I have is that you are setting the comparison option to trim trailing spaces. You may want to check to see what EngineDataCompareOptions you are using throughout the program.
Brian Donahue
Posts: 6590
Joined: Mon Aug 23, 2004 9:48 am

Return to SQL Comparison SDK Previous Versions

Who is online

Users browsing this forum: No registered users and 0 guests