Error 880

Forum for users of Redgate's SQL Backup tool

Error 880

Postby kthiongo » Wed May 09, 2012 8:26 pm

Backup Jobs keep failing with the error message

5/9/2012 4:21:34 PM: Error 880: BACKUP DATABASE permission denied in database: (db_name)
5/9/2012 4:21:34 PM: SQL error 15157: Setuser failed because of one of the following reasons: the database principal 'DOMAIN\\USER' does not exist, its corresponding server principal does not have server access, this type of database principal cannot be impersonated, or you do not have permission.

The registry fix listed on the site doesn't work. :(
Posts: 2
Joined: Mon Apr 30, 2012 4:00 pm

Postby chriskelly » Thu May 10, 2012 9:31 pm

When you say that the registry fix doesn't work, could you give some clarification? Were you unable to locate the registry key, or create it, or something else?
Posts: 373
Joined: Mon Apr 19, 2010 12:44 pm
Location: Cambridge, UK

Postby kthiongo » Fri May 11, 2012 1:55 pm

We have a 64bit system so i added the SkipChecks registry key to
HKEY_LOCAL MACHINE\\Software\\Wow6432\\Red Gate\\SQL Backup\\BackupSettingsGlobal\\(LOCAL)

that didn't fix it

i tried the fix on the
HKEY_LOCAL MACHINE\\Software\\Red Gate\\SQL Backup\\BackupSettingsGlobal\\(LOCAL) folder and it worked
Posts: 2
Joined: Mon Apr 30, 2012 4:00 pm

Return to SQL Backup Previous Versions

Who is online

Users browsing this forum: No registered users and 0 guests