Scheduled Backup Never Starts

Forum for users of Redgate's SQL Backup tool

Scheduled Backup Never Starts

Postby psherwood » Fri Feb 24, 2012 9:01 pm

I've setup a scheduled backup that should kick off at 11pm every evening. It has been 4 days and it still won't automatically kick off.

Right above the Job it says "Your SQL Server Agent doesn't appear to be running". I've clicked the Start SQL Server Agent link and it never goes away. I've also tried going into services and starting the agent. It comes back and says it quit because no one was using it. Is the agent my problem?

How do I get this scheduled job to start when it's supposed to?
Posts: 4
Joined: Thu Feb 16, 2012 1:40 pm

Postby peter.peart » Mon Feb 27, 2012 10:00 am

Thanks for your post. SQL Backup relies on the SQL Server Agent to be running in order for a scheduled task to be run.

Unless you're using Task Scheduler and calling an executable from the command line, any sort of scheduled job running in SQL Server relies on the SQL Server Agent to be running.

I'd therefore take a closer look at the SQL Server Agent and see why that's stopping, as to the best of my knowledge it shouldn't just stop through inactivity.

Kind regards,

Peter Peart
Red Gate Software Ltd
+44 (0)870 160 0037 ext. 8569
1 866 RED GATE ext. 8569
Site Admin
Posts: 362
Joined: Tue Sep 02, 2008 8:58 am
Location: Top floor, RG towers with the cool kids

Postby psherwood » Tue Feb 28, 2012 2:50 pm

I went into Services and looked at the properties of Server Agent. It was set to run under the Network Service user. I then looked at SQL Server and it was set to run under Local System Account. I then changed Server Agent to run under Local System Account and started it. It stayed running.

My scheduled backup completed successfully last night! Thanks for your help.

Posts: 4
Joined: Thu Feb 16, 2012 1:40 pm

Return to SQL Backup Previous Versions

Who is online

Users browsing this forum: No registered users and 0 guests