Problem with periods in output filenames

Forum for users of SQL Packager database archive utility

Problem with periods in output filenames

Postby ladenedge » Fri Jan 20, 2012 12:52 pm

Hello. I'm having some trouble using SQL Packager with certain filenames in the /name: option - specifically those containing '.' and '-'. Here are some sample outcomes:
  • /name:upscript.R46535_to_5.0.441 (doesn't work)
  • /name:upscript.R46535_to_5_0_441 (works)
  • /name:upscript.R46535_to_5-0-441 (doesn't work)
  • /name:upscript-R46535_to_5_0_441 (doesn't work)
  • /name:upscript_R46535_to_5_0_441 (works)

Here's the error we're seeing:

Code: Select all
Creating package...
Error: Error occurred whilst creating package 'upscript-R46535_to_5_0_441' in 'C:\\TeamCity\\buildAgent\\work\\33bce5bddfbed9dd\\.': Compilation errors:
c:\\Users\\jay\\AppData\\Local\\Temp\\5\\Red Gate\\PEed66b3f9-04fe-4b57-8d6a-6ef3e95ff9e4.cs(6,27) : error CS1514: { expected
<repeated several times>

We're also using the /scriptsource and /makeexe options, fwiw. Is there a workaround for this issue, or am I possibly doing something wrong?
Posts: 2
Joined: Wed Jan 11, 2012 5:17 pm
Location: United States

Postby Brian Donahue » Mon Jan 23, 2012 12:23 pm

Sorry to say, you can't have dots in the package filename. The reason for this is Packager uses the filename in the packager template as the .NET type name for the code, and a .NET type can't have dots in it, as they are used as separators.

Sorry for the inconvenience.
Brian Donahue
Posts: 6590
Joined: Mon Aug 23, 2004 10:48 am

Return to SQL Packager Previous Versions

Who is online

Users browsing this forum: No registered users and 1 guest