Connecting to Denali DB for Compare

Forum for users of SQL Compare schema synchronization utility

Connecting to Denali DB for Compare

Postby bcpreece » Tue Sep 27, 2011 10:47 pm

I have been trying to compare our current production environment to a new Denali environment we are building. In the Registering Data Sources step when trying to read assembiles on the Denali DB an error is raised, "ExecuteReader: CommandText property has not been initialized."

Is the current version of SQL Compare compatible with Denali? Is there any way we can get around this error?

Thanks!
bcpreece
 
Posts: 32
Joined: Mon Mar 26, 2007 7:52 pm

Postby james.billings » Fri Sep 30, 2011 8:47 am

We don't officially support Denali yet I'm afraid. We should be releasing an EAP of 9.5 soon (keep an eye on the forums) which should improve on this however.
james.billings
 
Posts: 1122
Joined: Wed Jun 16, 2010 10:10 am
Location: Red Gate

Postby bcpreece » Fri Sep 30, 2011 2:15 pm

I ended up sending an error report back from the application and was automatically sent a message back with a patch taking compare to 9.1. I was then able to connect to a Denali database.
bcpreece
 
Posts: 32
Joined: Mon Mar 26, 2007 7:52 pm

Postby james.billings » Fri Sep 30, 2011 2:16 pm

That's good to hear- there may still be the odd parts that give trouble but they should get tackled soon
james.billings
 
Posts: 1122
Joined: Wed Jun 16, 2010 10:10 am
Location: Red Gate


Return to SQL Compare Previous Versions

Who is online

Users browsing this forum: Bing [Bot] and 1 guest