FieldMapping not valid for MatchingMappings

Compares and synchronizes SQL database content.

FieldMapping not valid for MatchingMappings

Postby Adamant22 » Fri Aug 05, 2011 9:12 pm

Anyone ever seen this message?
This happens on the Mapping step when comparing the databases.

I ran SQL Compare first and the database structure is the same.
Posts: 1
Joined: Fri Aug 05, 2011 9:09 pm

Postby Brian Donahue » Mon Aug 08, 2011 10:38 am

As far as I know, this exception should not happen in SQL Data Compare because it should prevent you from being able to map columns that can't be compared because of a difference in the datatype.

Usually I see this message coming from SQL Comparison SDK apps. If you are using DataCompare.Engine.dll, I'd suggest throwing in some logic to check the MappingStatus field of every column mapping before you proceed to the comparison phase.
Brian Donahue
Posts: 6590
Joined: Mon Aug 23, 2004 9:48 am

Postby Brian Donahue » Mon Aug 08, 2011 4:26 pm

The problem turned out to be with Data Compare after all, and the fix was to create a new project. The old project had some outdated schema information after some column datatypes had been changed.

Normally this wouldn't cause a problem so I suspect maybe the project had been created in an older version of Data Compare, but I've got no way of checking that.
Brian Donahue
Posts: 6590
Joined: Mon Aug 23, 2004 9:48 am

FieldMapping not valid for MatchingMappings.

Postby kipb7 » Thu Aug 18, 2011 4:19 pm

I still get this error in SQL Data Compare

In the past, I've just created a new project. It is tiresome to re-discover the various settings I had set for comparing certain database pairs.
Perhaps the product could give a more descriptive message, such as which table or column, or what we can do about it?
Posts: 16
Joined: Mon Feb 07, 2011 11:43 pm

Postby tschlarm » Mon Jul 23, 2012 8:52 pm

This error is still present in
Posts: 19
Joined: Tue Nov 28, 2006 9:24 pm

Fix Found

Postby redkev » Thu Mar 07, 2013 8:31 pm

We were receiving the same error and found that it was due to a single table that had changed schema and the comparison file no longer could reconcile the mappings. To fix, you can open the .sdc file in a text editor (I recommend Notepad++) and cut out the bad table nodes. Then you can open the file in RedGate, re-select the table, and re-compare. Hope this helps!

Posts: 1
Joined: Thu Mar 07, 2013 8:23 pm
Location: Wayne, PA

temp fix

Postby icecurtain » Thu Jan 23, 2014 3:53 pm

I found and easier fix open,don't open by program but by SSMS select source and target the launch data compare it seems to create the project from there OK.

This caused a few hours of frustration.
Posts: 11
Joined: Mon Jan 18, 2010 5:11 pm

Re: FieldMapping not valid for MatchingMappings

Postby dei401 » Wed Feb 25, 2015 5:39 pm

Thank you for your comment Brian Donahue » Mon Aug 08, 2011 11:26 am. This solved my issue.
SQL Data Compare Standard Edition
Posts: 1
Joined: Wed Feb 25, 2015 5:31 pm

Return to SQL Data Compare Previous Versions

Who is online

Users browsing this forum: No registered users and 0 guests