"Input string was not in a correct format" with Perforce

A SQL Server Management Studio add-in to source control your database in Subversion or Team Foundation Server.

"Input string was not in a correct format" with Perforce

Postby geoffrobinson » Fri Jun 24, 2011 8:05 pm

Using Perforce, I'm trying to link an existing Perforce depot with a pre-existing database. I'm getting the same error from this thread:
http://www.red-gate.com/messageboard/vi ... hp?t=11607

I'm looking at the suggestions from that thread and I saw this:
"I think this is issue SOC-1369, which occurs if you link a non empty db to an existing repo and the SQL contains curly braces {}. We are looking into a fix for this. "

Getting rid of the curly braces worked for the person, but I have no idea where the curly braces are or what the root cause is. Plus, I'm using Perforce instead of SVN.

Does anyone have any suggestions on what I should be doing or where I should be looking?

Thanks for any help in advance.
Posts: 3
Joined: Thu Apr 21, 2011 7:20 pm
Location: Philadelphia, PA, USA

Postby james.billings » Mon Jun 27, 2011 3:00 pm

For other users coming across this post, the problem has been tracked down to a hex value being assigned to a parameter in a stored procedure. As SQL Server seems to accept this as valid syntax, it's possibly a bug, so we'll check over it.
Posts: 1122
Joined: Wed Jun 16, 2010 10:10 am
Location: Red Gate

Return to SQL Source Control Previous Versions

Who is online

Users browsing this forum: No registered users and 0 guests