Commit screen showing identical function as an edit

A SQL Server Management Studio add-in to source control your database in Subversion or Team Foundation Server.

Commit screen showing identical function as an edit

Postby wtjones » Tue Mar 15, 2011 7:53 pm

I added a DB to SC for the first time and performed the initial commit on all objects. When I immediately refreshed the commit changes screen it detected an edit to a UDF (no one is on this db) but the differences pane does not show any any changes.

I tried show -> Line Differences and even Show -> Groups but all it did was break it into 2 sections:

User Defined Function = User Defined Function

Permissions = Permissions

This validates the fact the the version in SC is the same as the db.

When I recommit the object it shows up again. I then ran an alter with no effect.

I also tried putting the object into another db with slightly different GRANT statments and it worked fine. Seems the issue is confined to the original database.

Anyone else come across this?
Posts: 14
Joined: Tue Jan 08, 2008 3:27 pm

Return to SQL Source Control Previous Versions

Who is online

Users browsing this forum: No registered users and 0 guests