Error when checking the "Kept in memory only by disposed obj

Memory profiling for .NET developers

Error when checking the "Kept in memory only by disposed obj

Postby jasolution » Tue Sep 15, 2009 1:39 pm

When profiling an website hosted in IIS, when I check the box under Common Leak Indicators called "Kept in memory only by disposed objects", I get this pop up error and the output will not display:

Specified argument was out of the range of valid values.Parameter name: identifier
at dq.ObjectWithIdentifier(Int32 identifier)
at bv.b()
at bv.a()
at bv.get_ConnectedToRootStrong()
at bq.get_ConnectedToStrongRoots()
at bc.get_ConnectedToStrongRoots()
at cX.Select(IGraphAnalysis analysis, IComparisonAnalysis comparison)
at cx.Select(IGraphAnalysis analysis, IComparisonAnalysis comparison)
at cW.Select(IGraphAnalysis analysis, IComparisonAnalysis comparison)
at ct.Select(IGraphAnalysis analysis, ISnapshotComparison comparison)
at RedGate.Memory.Controller.ControllerState.ControllerState.get_FilteredCurrentObjects()
at RedGate.Memory.Controller.ControllerState.ControllerState.get_CategorisedCurrentObjects()
at i.get_CategorisedCurrentObjects()
at N.a()
at N.b(Object , GenericEventArgs`1 )
at System.EventHandler`1.Invoke(Object sender, TEventArgs e)
at i.a(StateUpdateType )
at i.set_FilterPanelState(IFilterPanelState value)
at w.a(Object , GenericEventArgs`1 )
at W.<>c__DisplayClass3.<.ctor>b__1()
at O.b()

This is running on a fully patched 32-bit Windows 2003 Server machine with ample RAM and free disk space available.
Posts: 9
Joined: Tue Oct 07, 2008 3:52 am

Postby Brian Donahue » Wed Sep 16, 2009 2:11 pm

Hi Jason,

I believe this could also be a symptom of ASP .NET's specialized multithreaded garbage collection disposing some .NET objects behind Profiler's back. Disabling "serverGC" should get memory profiling working for you. Please see for the instructions on how to turn it off.
Brian Donahue
Posts: 6590
Joined: Mon Aug 23, 2004 9:48 am

I have this problem too

Postby engica1 » Tue Oct 20, 2009 11:18 am

I am running Server 2008 RC2
Running against IIS on port 80

setting gcServer="false" did not seem to help :(

Martin Sarosi
Posts: 1
Joined: Tue Oct 20, 2009 11:15 am

Postby Brian Donahue » Tue Oct 20, 2009 5:06 pm

We think that serverGC can also be set in the "global" web.config in the CONFIG folder of the .NET installation, and maybe even in Machine.config. You may want to check those places as well as the local web.config.
Brian Donahue
Posts: 6590
Joined: Mon Aug 23, 2004 9:48 am

Return to ANTS Memory Profiler Previous Versions

Who is online

Users browsing this forum: No registered users and 0 guests