ZLib decompression error when encrypted

SQL Backup to MTF Converter - A user interface to the SQB2MTF.exe command line utility for converting SQL Backup files (*.sqb) into native SQL Server (uncompressed) backup files.

ZLib decompression error when encrypted

Postby bdill » Tue Jul 21, 2009 9:12 pm

SQLBackup version:
SQBConverterGUI version:
(includes RgSqbConvHelper.dll ver:
and RedGate.Shared.Controls.dll ver:

When I first tried to convert an encrypted *.sqb to *.bak, I got the following error:

Code: Select all
Data decompression error: ZLib decompression error: data error

I verified the files using an MD5 utility, and they matched, so it isn't a file copying issue.

My password had special characters and was long (30 chars), so I made another encrypted backup with a small password using only letters/numbers. I got the same error.

I did another full backup, but this time I did NOT encrypt the backup. That *.sqb file converted successfully.

1) Can anybody at Red-Gate replicate this behavior?
2) Is my version of the SQB2MTF utility incompatible with the my version of SQL Backup version?
Posts: 28
Joined: Tue Feb 15, 2005 9:02 pm
Location: Nashville, TN

Postby RBA » Mon Sep 07, 2009 12:56 pm

Hi bdill,

This is a known issue and has now been resolved in the latest build.

This fix will be present in the next minor release, but you can email me (robin.anderson {at} red-gate.com) for a copy of the latest exe and related drivers before then.

Robin Anderson
Red-Gate Software
Posts: 148
Joined: Fri Jun 05, 2009 11:13 am
Location: Cambridge

Return to SQB2MTF GUI utility

Who is online

Users browsing this forum: No registered users and 0 guests