Restore from file problem

Forum for users of Redgate's SQL Backup tool

Restore from file problem

Postby daveh » Thu Apr 24, 2008 10:07 pm

I have a roughly 2.7 GB backup of a database that was performed on one SQL Server which I have then copied to another SQL Server to restore. When load it in using the restore wizard the there is a small red x in the OK column. When I hold my mouse over this x the message, Could not retrieve information from the server about [path to backup file].

I have now tried it with two different backup files and receive the same error. Any assistance is greatly appreciated!

Posts: 2
Joined: Thu Apr 24, 2008 9:59 pm

Postby daveh » Thu Apr 24, 2008 10:18 pm

Err, I feel stupid (hey, it is 8:00 am on public holiday here and I'm at work!). It was actually just an issue with file permissions! I had copied the file itself to the server with a user who had domain admin permissions. I was then using SQL Backup from a remote PC on a different domain. As soon as I changed the permissions to make it accessible to any user on the machine, all was well!
Posts: 2
Joined: Thu Apr 24, 2008 9:59 pm

Same problem, no solution

Postby Bgfreeman » Sat Apr 24, 2010 10:32 am

I have a 28Gb backup file from a production server, copied to the mirror server. The database itself is 125Gb.

I have copied this same file to a Dev server and restored without problems.

On the mirror server I get the red 'X' and the tooltip states 'Could not retrieve information from the server about <filename>'

I set the permissions on the file, folder and parents to 'Everyone, Full Control' and nothing has changed. I've restarted SQLB as well.

It takes several hours to copy this file, so I don't want to have to do it again.

We're on a 14-day trial of SQLB, but if I can't use it then I don't see the point in purchasing it.
Posts: 15
Joined: Fri Apr 23, 2010 5:45 pm

Return to SQL Backup Previous Versions

Who is online

Users browsing this forum: No registered users and 0 guests