Error 'Unhandled BLOB type for 231.'

Undo for SQL Server.

Error 'Unhandled BLOB type for 231.'

Postby albsilva » Thu Jun 01, 2006 11:28 am

I'm getting this error when trying to recover some dropped tables.

I've managed to recover smaller tables (up to 20 records) but with others I get always this error.

I'm using version

Alberto Silva
Posts: 2
Joined: Thu Jun 01, 2006 11:21 am

Postby Neil Davidson » Sat Jun 03, 2006 5:12 pm


Is there any chance we can get hold of your live database file, transaction log, and any backups you're attaching?

If so, can you e-mail them to

- Neil
- Neil Davidson
Red Gate Software Ltd
Neil Davidson
Posts: 221
Joined: Wed Sep 08, 2004 11:00 am

Postby albsilva » Sun Jun 04, 2006 10:04 pm

Hi Neil,
I will attend the MEDC Europe this week and the following week I'll send you the files.

Alberto Silva
Posts: 2
Joined: Thu Jun 01, 2006 11:21 am

I am getting this error as well

Postby » Tue Oct 03, 2006 9:57 am

I have gotten all but one table in my database. One table where this error occurred finally worked however there is one that this error continues to appear on.
Posts: 1
Joined: Tue Oct 03, 2006 9:54 am

Postby Brian Donahue » Wed Oct 04, 2006 12:00 pm

I think this can happen if there is a significant schema change in a table. Basically, the backup file indicates that the BLOB column is one type (say, an TEXT) and then you change the column to another (say, NTEXT). Log Rescue will then try to retrieve this column as TEXT when it is not.

I don't see any workaround for this. We will definitely look into making Log Rescue more happy about schema changes. If you start with a more recent full backup and compare some more recent logs, I'd imagine that Log Rescue would work just fine.
Brian Donahue
Posts: 6590
Joined: Mon Aug 23, 2004 9:48 am

Solved yet ?

Postby ringersma » Fri Feb 23, 2007 6:27 pm

We're also having a problem that a BLOB 231 error is generated.
Has there been anyone who has come up with a workaround solution ?

Annoying also that shift-click for selecting multiple lines doesn't work in the interface so either full select or one-by-one. Tedious work :-(
Posts: 1
Joined: Fri Feb 23, 2007 6:16 pm

Return to SQL Log Rescue

Who is online

Users browsing this forum: No registered users and 0 guests