Error while updating.

Code and memory profiling for .NET developers.

Moderators: Brian Donahue, richardjm, StephenC

Error while updating.

Postby IGMikeS » Thu Jul 09, 2009 6:51 pm

I'm trying to upgrade from Ants Profiler 4 to 4.3.

The "Red Gate .NEt Bundle Installer" will not let me install. I get a message that says:

"The applications listed below are using files which need to be updated by the installer. Shut down these applications in order to carry on:

RedGate.Profiler.IISProfileHost
RedGate.Profiler.IISService"

I am not running any Redgate applications (expect, of course for the bundle installer itself). I've check my system Task manager and there is nothing RedGate on the list of applications or processes (except for the Bundle Installer, again).

What are these programs and how do I shut them down so I can update?
IGMikeS
 
Posts: 4
Joined: Wed Jan 11, 2006 8:31 pm

Postby Brian Donahue » Fri Jul 10, 2009 5:32 pm

That's a good question. These two processes are services installed by ANTS Profiler as a way of getting the necessary access to IIS to profile web applications. If you stop "ANTS Performance Profiler" and "ANTS Memory Profiler" services in the services control panel, this will allow the installation to continue.
Brian Donahue
 
Posts: 6669
Joined: Mon Aug 23, 2004 10:48 am

Postby IGMikeS » Mon Jul 13, 2009 2:09 pm

Yep. that worked. :)

I don't actually do any IIS work - I'm a WinForm developer. So do I need these services at all? Should I just turn them off in the Services control panel?
IGMikeS
 
Posts: 4
Joined: Wed Jan 11, 2006 8:31 pm

Postby Brian Donahue » Mon Jul 13, 2009 3:59 pm

Yes, you can disable both ANTS Profiler services unless you need to profile web applications hosted in IIS or COM+ applications.
Brian Donahue
 
Posts: 6669
Joined: Mon Aug 23, 2004 10:48 am


Return to ANTS Profiler Previous Versions

Who is online

Users browsing this forum: No registered users and 0 guests