Installing to website that requires ASP.NET other than V2

Email archiving software for Exchange

Moderators: JonathanWatts, richardjm, Robert, Matthew Flatt

Installing to website that requires ASP.NET other than V2

Postby Matthew Flatt » Thu Apr 23, 2009 10:16 am

The User Archive Access (UAA) Service has a prerequisite of ASP.NET 2.0. This can cause problems if other applications using the same Application Pool require a different ASP.NET version.

To work around this you can create a new Application Pool in the IIS Manager for the UAA Service.

Windows 2003

In the IIS Manager, select the Application Pools folder: Actions>New>Application Pool.

The UAA Service will then need to be configured to use this new Application Pool.

Expand the Web Sites folder followed by the Web Site you installed the UAA Service on.
Select Properties of UAAService and on the Virtual Directory tab select the newly created Application Pool using the bottom drop down box.

Check the ASP.NET tab and make sure the ASP.NET version is set to 2.

Vista/Windows 2008

In the IIS Manager, select Application Pools>Add Application Pool.

Give the Application Pool a name and ensure the .NET Framework version is set to 2.

Expand the Web Sites folder followed by the Web Site you installed the UAA Service on.

Select the UAAService and choose Advanced Settings: Actions>Manage Application>Advanced Settings.

Select your newly created Application Pool.
Matthew Flatt
Test Engineer, HyperBac
Matthew Flatt
 
Posts: 253
Joined: Tue Jan 15, 2008 4:45 pm

Return to Exchange Server Archiver

Who is online

Users browsing this forum: No registered users and 1 guest