package database to install on SQL 2005

Packages and compresses schema and contents of SQL Server databases

Moderators: JonathanWatts, Chris Auckland, David Atkinson, david connell, Anu Deshpande, Michelle Taylor, james.billings, Marianne

package database to install on SQL 2005

Postby markfron » Thu Dec 04, 2008 5:09 pm

I am packaging a database from SQL2000 to SQL2005. It creates the package, and upon installation for a SQL 2005 database, it returns message "ORDER BY items must appear in the select list if the statement contains a UNION, INTERSECT or EXCEPT operator. ORDER BY items must appear in the select list if the statement contains a UNION, INTERSECT or EXCEPT operator"

However, when I copy the stored procedure and execute it manually it creates it in SQL 2005.

Is there an option on the packager to remove this requirement.

It seems that SQL2005 will accept the stored procedure as is from SQL 2000, so why is the packager returning the error?
markfron
 
Posts: 1
Joined: Thu Dec 04, 2008 4:59 pm

Postby eddie davis » Mon Dec 08, 2008 8:07 pm

Thank you for your post into the forum.

A support call has been created for you, the call reference is F0017616.

Can you please send to us (support@red-gate.com), a screen shot of the error message you get when you attempt to run the package?

Also the syntax that creates the Stored Procedure you are having problems with?

Please place in the Subject heading of the e-mail your call reference F0017616.

Many Thanks
Eddie
Eddie Davis
Technical Support Engineer
Red Gate Software Ltd
E-mail: support@red-gate.com
eddie davis
 
Posts: 942
Joined: Wed Jun 14, 2006 3:47 pm
Location: Red Gate Software


Return to SQL Packager 6

Who is online

Users browsing this forum: No registered users and 0 guests