click once?

Forum for users of SQL Packager database archive utility

Moderator: David Atkinson

click once?

Postby jbrown » Fri Sep 19, 2008 7:29 pm

When we do a "click once" publish of our C# packager and try to run it, the user will briefly see the cmd prompt flash, and then the application just disappears - no form ever appears on the screen.

To get it working this far we had to set the RedGate dll's "copy local" to true, is there anything else we're missing?
jbrown
 
Posts: 12
Joined: Sat Sep 13, 2008 2:05 am

Postby Brian Donahue » Fri Oct 03, 2008 6:05 pm

Hi,

Here is my experience with ClickOnce and Packager. I output the package as a C# project so that I could use the "publish" menu item from Visual Studio, a fair shade easier than actually working out how ClickOnce actually works! After I published, I tried the "install" button on the website where I had published it. At that point it told me I needed RedGate.Compression.Zlib.dll in my GAC, so I did that.

Next I clicked Install again, and got the flashing command prompt, same as you.

I then went back into Visual Studio and edited PackageMain.Main() to put a Console.ReadLine right before "return". Now I can see what is in the command window and it says
You don't have sufficient permissions to run an executable located on another machine

My guess is that in all likelyhood it's a matter of adjusting your zone security in the .NET Framework configuration wizard to allow assemblies to run across the Internet. Maybe there is another way around this issue, but at least you can find out what the problem might be.

I hope this helps!
Brian Donahue
 
Posts: 6670
Joined: Mon Aug 23, 2004 10:48 am


Return to SQL Packager Previous Versions

Who is online

Users browsing this forum: No registered users and 0 guests