Illegal characters in path.

Analyse application memory usage, including loaded libraries, system heap memory and .NET memory.

Illegal characters in path.

Postby rdugre » Tue Apr 03, 2007 4:04 pm

Just a minor issue. When I attempt to open the "aspnet_wp.exe" process, I get the message "Illegal characters in path." It seems to open the process successfully, but I'm assuming it's complaining about the underscore in the process name.
rdugre
 
Posts: 9
Joined: Mon Feb 06, 2006 5:52 pm

Postby Brian Donahue » Sun Apr 20, 2008 10:59 pm

There seems to be some wierdness in the environment of the worker process application -- aspnet_wp.exe's path includes a question-mark. .NET's System.IO.File namespace seems incapable of resolving this path, which seems to me a bug in the framework. See here for more information.

Perhaps creating an application config file for Memory Tracker forcing the supportedRuntime to .NET 2.0 will make this work. I'm not in a position to try it right now, but I'll see if I can look into it later.

Thanks!
Brian Donahue
 
Posts: 6670
Joined: Mon Aug 23, 2004 10:48 am

Postby Brian Donahue » Mon Apr 21, 2008 10:16 am

Hi,

Creating a RedGate.Memory.UI.exe.config file does solve the invalid path problem for aspnet_wp.exe:
Code: Select all
<?xml version="1.0" encoding="utf-8" ?>
<configuration>
   <startup>     
      <supportedRuntime version="v2.0.50727"/>
   </startup>
</configuration>
There seems to be a problem accessing some bit of memory now, however. Hopefully it works for you.
Brian Donahue
 
Posts: 6670
Joined: Mon Aug 23, 2004 10:48 am


Return to Memory tracker

Who is online

Users browsing this forum: No registered users and 1 guest