Problems with Windows Authentication

Forum for users of ANTS web server load testing tool

Moderator: Brian Donahue

Problems with Windows Authentication

Postby kawaki » Mon Sep 18, 2006 10:31 am

Hi there,

I just downloaded Ants Load v. 1.75 i belive, and is trying to set this up to access a website that we develop.

I keep getting iis server errors upon connecting
"HTTP Error 401.2 - Unauthorized: Access is denied due to server configuration. Internet Information Services (IIS)"

The user i logged into the server with works with this application if I open IE, but when antsload opens the IE i have no credintials.

The site starts an ocx upon connection and passes this along to our server software (named antserver :-) ) and passes this on to Microsoft analysis services.

So we use kerberos for authentication, as we use constrained delegation in windows 2003.

How could i record a script when needing to use kerberos, i have tried starting antsload as the domain administrator but the internet explore it opens does not have the credintials that the domain user have, for reasons i dont know. If starting an internet explorer standard it works w/o problems.

I have the same problem with Mercury's Load Runner, but I can atleast run the scripting in there explore, just not play the recorded script as it also complains about security.
kawaki
 
Posts: 1
Joined: Fri Sep 15, 2006 1:58 pm
Location: Denmark

Postby Brian Donahue » Tue Sep 19, 2006 12:44 pm

Hello,

ANTS Load has the opposite problem from Mercury in that the script recorder can't do Windows Authentication, but the playback can, with modification. There is more information here about how to potentially use ANTS Load with Windows Authentication. Note it only supports NTLM 1 and 2, but as far as I know a web browser isn't capable of Kerberos?

http://www.red-gate.com/messageboard/vi ... php?t=1931
Brian Donahue
 
Posts: 6668
Joined: Mon Aug 23, 2004 10:48 am


Return to ANTS Load

Who is online

Users browsing this forum: No registered users and 1 guest