http 401

SQL Server performance monitoring and alerting

Moderators: Colin Millerchip, priyasinha, Adam, chriskelly

http 401

Postby teddy » Fri Jun 20, 2014 10:33 am

Hi,

I have installed sql monitor 4.1 (also tried 3.5 and get same thing) on a win2k3 server.

When I try to use my browser (tried ff, ie and chrome) to browse the site, all I get is a blank page.

If I look at the http headers I see:

HTTP/1.0 401 Unauthorized
Date: Fri, 20 Jun 2014 09:31:36 GMT
Server: Mono.WebServer2/0.2.0.0 Win32NT
X-AspNet-Version: 2.0.50727
X-AspNetMvc-Version: 2.0
Cache-Control: private
Content-Length: 0
Keep-Alive: timeout=15, max=100
Connection: Keep-Alive


I found this in the base deployment log for sql monitor 3:

NHibernate.Type.CustomType - the custom type 'RedGate.Response.Common.Domain.Credentials' handled by 'RedGate.Response.Common.Persistence.NHibernate.UserTypes.CredentialsUserType' is not Serializable:


what can I do? i really want to trial this and this sucks big time.
teddy
 
Posts: 1
Joined: Fri Jun 20, 2014 10:31 am

Postby chriskelly » Fri Jun 20, 2014 11:54 am

It looks like the WebServer is trying to get authorisation. Can you confirm the following:

- what is the URL you are using?
- are you using a web browser on the machine where SQL Monitor is installed?
- is the SQL Monitor Web service Started?
- have you changed the user account assigned to it?
Chris Kelly
Technical Support Engineer
chriskelly
 
Posts: 330
Joined: Mon Apr 19, 2010 1:44 pm
Location: Cambridge, UK


Return to SQL Monitor 4

Who is online

Users browsing this forum: No registered users and 1 guest