Smart Assembly 6.8.0.121 crashes on startup

.NET obfuscator and automated error reporting

Moderators: Luke Jefferson, melvyn.harbour, dom.smith

Smart Assembly 6.8.0.121 crashes on startup

Postby Ognyandim » Thu Mar 27, 2014 1:40 pm

Hi I have recently updated SA to the last version 6.8.0.121. After that it started to crash on program start. I have reinstalled the application but still no effect. My teammate experiences the same problem. The error states "The type initializer for '%a cross sign here and some white space%' threw an exception."

Here is a screenshot :
http://dox.bg/files/dw?a=6f0328b35c
Ognyandim
 
Posts: 10
Joined: Tue Jan 08, 2013 1:31 pm
Location: Sofia, Bulgaria

Postby jessica.ramos » Thu Mar 27, 2014 6:23 pm

Hi Ognyan!

From the error in your screenshot it looks as though there may be an issue connecting to the SQL database you are using to store SmartAssembly information.

Could you kindly try changing the database settings from your SmartAssembly.settings file in C:\\ProgramData\\Red Gate\\SmartAssembly ?

-Please open the file in a text editor and change DatabaseEngine="0"
-SmartAssembly should open alright again.
-Please then go to Tools>Options from the SmartAssembly UI and change your Reports Database options back to the SQL Server option, making sure that it connects successfully before closing SmartAssembly
Jessica Ramos
Technical Support
Red Gate Software Ltd.
jessica.ramos
 
Posts: 235
Joined: Mon Apr 23, 2012 1:13 pm


Return to SmartAssembly 6

Who is online

Users browsing this forum: No registered users and 0 guests