Bug on windows server 2012 r2

.NET obfuscator and automated error reporting

Moderators: Luke Jefferson, melvyn.harbour, dom.smith

Bug on windows server 2012 r2

Postby janne » Sun Mar 16, 2014 2:11 pm

I'm using the trial version of SmartAssembly v6.8.0.121, and is unable to use the gui interface to obfuscate .net 4.5 assemblies. SmartAssembly says that i have not installed .net 4.5. However, windows server 2012 r2 comes bundled with .net 4.5 and i can even run the assemblies! So i have .net 4.5, and when i tested SmartAssembly CLI, it worked fine! So it seems like a small gui bug... i even tested on windows server 2012 (not r2) and it still fails.
janne
 
Posts: 4
Joined: Sun Mar 16, 2014 2:04 pm

Postby Chris.Allen » Mon Mar 17, 2014 4:43 pm

Please use .Net dev pack on SA build machines:

http://www.microsoft.com/en-us/download ... x?id=40772
Chris.Allen
 
Posts: 594
Joined: Thu Mar 12, 2009 4:17 pm

Re:

Postby janne » Mon Mar 17, 2014 7:13 pm

Chris.Allen wrote:Please use .Net dev pack on SA build machines:

http://www.microsoft.com/en-us/download ... x?id=40772


I have already tried that, it still doesn't work:

Image
janne
 
Posts: 4
Joined: Sun Mar 16, 2014 2:04 pm

Postby janne » Tue Mar 18, 2014 11:03 pm

Nor can i get it to work on windows server 2008, but your sysreq clearly states that it should work on windows server 2008: http://documentation.red-gate.com/displ ... quirements
janne
 
Posts: 4
Joined: Sun Mar 16, 2014 2:04 pm

Postby Chris.Allen » Thu Mar 20, 2014 2:28 pm

Chris.Allen
 
Posts: 594
Joined: Thu Mar 12, 2009 4:17 pm

Postby janne » Sat Mar 22, 2014 6:28 pm

I smell success, it seems to work!

Note that the win 8 sdk installer fails in win srv 2012 if "Application Verifier For Windows" is checked.
janne
 
Posts: 4
Joined: Sun Mar 16, 2014 2:04 pm


Return to SmartAssembly 6

Who is online

Users browsing this forum: No registered users and 1 guest