DM does not point the Virtual Directory to physical path

Automated deployment for web applications and databases

Moderators: Mike Upton, justin.caldicott, Sean.newham, csmith, chirayu, DavidSimner, david.conlin

DM does not point the Virtual Directory to physical path

Postby rjayakumar » Wed Aug 21, 2013 7:55 am

I am trying to use physical path to deploy as
x:\\AppName_$(RedGateReleaseNumber) and DM though created the physical folder - it failed to point the properties of virtual directory to the newly created folder.

I am missing any other setting?

The other settings are as below

RedGateCreateWebSiteOnPort - 80
RedGateNotAWebSite - True
RedGatePurgePackageDirectoryBeforeCopy - True
RedGateWebSiteName - Default Web Site/AppName
________
Cheers,
Raghunandan
rjayakumar
 
Posts: 25
Joined: Wed Aug 21, 2013 7:49 am
Location: Bangalore

Postby Mike Upton » Wed Aug 21, 2013 3:19 pm

Hi,

I've already replied to your support e-mail about this, but for the benefit of any others who might be reading this...

Deployment Manager will not update the virtual directory setting in IIS if the RedGateNotAWebSite variable is set to true, because the purpose of the RedGateNotAWebSite variable is to disable any IIS configuration. The documentation about the various RedGateXXX variables is available here.
Mike Upton

Software Engineer
Red Gate Software Ltd.
Mike Upton
 
Posts: 157
Joined: Wed May 11, 2011 8:04 am
Location: Red Gate

Postby rjayakumar » Fri Aug 23, 2013 8:51 am

Thanks Mike.

I have set the variable to False and its working as expected now.

The reason for setting the value as TRUE was the naming used - when the parameter reads NotAWebSite --- it meant as virtual directory and hence it was set as True. :)
________
Cheers,
Raghunandan
rjayakumar
 
Posts: 25
Joined: Wed Aug 21, 2013 7:49 am
Location: Bangalore


Return to Deployment Manager

Who is online

Users browsing this forum: No registered users and 1 guest