Connection failed (Bad data)

SQL Server performance monitoring and alerting

Moderators: eddie davis, priyasinha, Adam, chriskelly, Chris Lambrou, Chris Spencer

Connection failed (Bad data)

Postby Lynchie435 » Wed May 29, 2013 5:07 pm

Afternoon,

I seem to be having an issue with my perfmon and getting the SQL Monitor to connect to the data.

I have previously looked at an older post saying this is an issue between 32bit and 64bit OS/SQL. I can confirm that I am on both 64bit OS and 64bit SQL and still have the issue.

I get the following in the log:

Perfmon data is missing objects: SQLServer:Access Methods, SQLServer:Buffer Manager, SQLServer:Databases, SQLServer:General Statistics, SQLServer:Latches, SQLServer:Locks, SQLServer:Memory Manager, SQLServer:SQL Statistics. Possible causes include performance counter library corruption, or a 32-bit/64-bit mismatch between Windows and the performance counter provider (e.g. SQL Server).

I can confirm that these objects do exist as I can select them from the performance monitor from within Task Manager and can view the data myself.

Can some light be shed please.

Regards,

James
Lynchie435
 
Posts: 11
Joined: Mon May 20, 2013 9:42 am

Postby Lynchie435 » Thu May 30, 2013 6:18 pm

Please consider this resolved.

We had to perform a reboot of the server this evening after some work was carried out with our bespoke software solution and this resolved the perfmon issues.

Many Thanks
Lynchie435
 
Posts: 11
Joined: Mon May 20, 2013 9:42 am


Return to SQL Monitor 3

Who is online

Users browsing this forum: No registered users and 0 guests

cron