Common Language Runtime detected an invalid program

Code profiling for .NET developers.

Moderators: AndrewH, melvyn.harbour, james.billings, Laura Morley, dene.boulton

Common Language Runtime detected an invalid program

Postby coallen » Mon Apr 01, 2013 9:16 pm

Hi,

I've read through the various other posts regarding similar problems but none of the fixes/work-arounds seem to apply. I am able to run ANTS Memory Profiler without any issue but when I try to run the Performance Profiler, I get the following error:

Common Language Runtime detected an invalid program.
Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: System.InvalidProgramException: Common Language Runtime detected an invalid program.

Source Error:

An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.

Stack Trace:


[InvalidProgramException: Common Language Runtime detected an invalid program.]
System.Web.HttpApplication.System.Web.IHttpAsyncHandler.BeginProcessRequest(HttpContext context, AsyncCallback cb, Object extraData) +0
System.Web.HttpRuntime.ProcessRequestInternal(HttpWorkerRequest wr) +428




--------------------------------------------------------------------------------
Version Information: Microsoft .NET Framework Version:4.0.30319; ASP.NET Version:4.0.30319.547

Any possible solutions/work-arounds?
coallen
 
Posts: 2
Joined: Fri Jan 18, 2013 7:41 pm

Postby jessica.ramos » Tue Apr 02, 2013 11:13 pm

Hi there,

Thanks for you post!

You should be able to work around this if you lessen the instrumentation used in profiling (the memory profiler does not instrument)--are you able to profile successfully if you use method level timings or sampling mode?

Also, have you been able to try profiling on another machine?
Jessica Ramos
Technical Support
Red Gate Software Ltd.
jessica.ramos
 
Posts: 235
Joined: Mon Apr 23, 2012 1:13 pm

Postby coallen » Wed Apr 03, 2013 10:33 pm

If I change the profiling mode to "Sample method-level timings (fastest, least detail, no hit counts)" then profiling does work. However, not much detail is provided. Any idea as to how I can get one of the other, more detailed methods to work?
coallen
 
Posts: 2
Joined: Fri Jan 18, 2013 7:41 pm

Postby jessica.ramos » Thu Apr 04, 2013 5:07 pm

Ah okay, it's good to hear that sampling at least works!

I think you may have already read about how certain security updates have caused similar errors recently. May I ask what operating system you are running? The update KB2742596 was causing problems on Windows XP and Windows Server but you can also find it's equivalent on other OS's here: http://technet.microsoft.com/en-us/secu ... n/ms13-004

Could you kindly check if you have that update or it's equivalent installed and try uininstalling it?
Jessica Ramos
Technical Support
Red Gate Software Ltd.
jessica.ramos
 
Posts: 235
Joined: Mon Apr 23, 2012 1:13 pm


Return to ANTS Performance Profiler 7

Who is online

Users browsing this forum: No registered users and 0 guests

cron