FILLFACTOR = 90 added to table scripts

Compares and synchronizes SQL Server databases, backups and scripts.

Moderators: JonathanWatts, Chris Auckland, David Atkinson, eddie davis, Anu Deshpande, Michelle Taylor, alice.easey, james.billings, chengvoon.tong

FILLFACTOR = 90 added to table scripts

Postby jpeckham » Sun Nov 18, 2012 5:14 am

When I run SQL Compare from command line with /scriptfile option to DB it adds FILLFACTOR=90 to every table then I have to undo changes because those aren't in source control of the linked DB that I have.

This comes up often because I delete my db, restore a backup to do some troubleshooting, then use sqlcompare to reload it without unlinking or re-linking. It's a time saver for me because for some reason it takes 10minutes to link our database and it only takes me a few seconds to regenerate the DB from SQL Compare.

This is mostly just a nuisance that I have to go undo changes to get back to work.
jpeckham
 
Posts: 3
Joined: Tue Mar 29, 2011 6:01 pm
Location: merriam,ks

Postby stanori » Tue Nov 20, 2012 6:53 pm

Hi jpeckham,

Thanks for your forum post. In regards to the fill factor setting, by default the command line doesnt set this option. You can try adding the following option to your command line to set the "Ignore Fill Factor setting":

/options:IgnoreFillFactor

Best Regards,
Steve
_________________
Steve Tanori
Product Support
Red Gate Software Ltd.
866-997-0378
stanori
 
Posts: 84
Joined: Mon Apr 23, 2012 1:13 pm


Return to SQL Compare 10

Who is online

Users browsing this forum: No registered users and 0 guests