Workaround for performance issues on large database schemas

Provides intelligent code completion for SQL Server editors.

Moderators: JonathanWatts, David Atkinson, Anu Deshpande, Paul Stephenson, Michelle Taylor, Mike Upton, justin.caldicott, Aaron Law

Workaround for performance issues on large database schemas

Postby David Atkinson » Tue Jul 10, 2012 1:11 pm

If you are having issues with SQL Prompt as it tries to cache databases with a very large number of schema objects, the following option is available to you.

As of SQL Prompt 5.3 you can edit %LOCALAPPDATA%\\Red Gate\\SQL Prompt 5\\RedGate_SqlPrompt_Engine_EngineOptions.xml and change <MaxSupportedColumns> to a value like 2000000.

Any database with more than the configured total number of columns across all tables will just not be cached by SQL Prompt.
David Atkinson
 
Posts: 1124
Joined: Mon Dec 05, 2005 4:54 pm
Location: Twitter: @dtabase

Return to SQL Prompt 5

Who is online

Users browsing this forum: No registered users and 0 guests