Problem with SQL Profiler and Sql Prompt

Provides intelligent code completion for SQL Server editors.

Moderators: JonathanWatts, David Atkinson, Anu Deshpande, Paul Stephenson, Michelle Taylor, Mike Upton, justin.caldicott, Aaron Law

Problem with SQL Profiler and Sql Prompt

Postby grothag » Fri Jun 29, 2012 8:38 pm

I am trying to run trace on a database, but there are so many queries from Sql Prompt that I can't use trace at all (repeating same queries all the time, 3-5 queries per second). Why is Sql Prompt querying database so much ? How can I turn that off ? Turning off management studio is not an option.
grothag
 
Posts: 1
Joined: Fri Jun 29, 2012 8:31 pm

Postby chriskelly » Mon Jul 02, 2012 8:16 pm

SQL Prompt is refreshing the local cache of information so that the Code Completion and Expand Wildcard features can give you the most accurate results.

The simple way to turn this off is by disabling SQL Prompt. Simple navigate to the SQL Prompt menu and select "Disable Code Suggestions".
Chris Kelly
Technical Support Engineer
chriskelly
 
Posts: 330
Joined: Mon Apr 19, 2010 1:44 pm
Location: Cambridge, UK

Postby chriskelly » Mon Jul 02, 2012 8:22 pm

Additionally, there is a SQL Prompt labs feature which allows you to disable the refresh. This means that the various functionality remains enabled, but that you have to manually refresh the local cache.

http://sqlprompt.posterous.com/auto-ref ... ions-72662
Chris Kelly
Technical Support Engineer
chriskelly
 
Posts: 330
Joined: Mon Apr 19, 2010 1:44 pm
Location: Cambridge, UK


Return to SQL Prompt 5

Who is online

Users browsing this forum: No registered users and 0 guests