Out of memory exception after project build, close/reopen

.NET obfuscator and automated error reporting

Moderators: Luke Jefferson, melvyn.harbour, dom.smith

Out of memory exception after project build, close/reopen

Postby EricPeterson » Wed Nov 30, 2011 5:43 pm

Using version 6.5.2.21 Pro

if SA is closed and i open it and my project, then build my project, things work as expected.

if i then close the project (and leave SA open), then reopen my project and try to rebuild my project, i am getting a

System.OutOfMemoryException

If i close SA between runs, it works fine.

let me know if you want me to do anything else (extended logging, etc) on this.
Eric R Peterson
EricPeterson
 
Posts: 5
Joined: Thu Nov 03, 2011 10:15 pm

Postby Chris.Allen » Thu Dec 01, 2011 6:17 pm

It is a known issue that SA does leak some memory upon each build, sorry. I will add this t the accumulation of reproductions we keep.

Can you tell us how much memory is used up by the SA project after 1 iteration please?
Chris.Allen
 
Posts: 594
Joined: Thu Mar 12, 2009 4:17 pm

Postby EricPeterson » Mon Dec 05, 2011 4:26 am

Just opening SA and loading my project:

SmartAssembly.exe SmartAssembly.exe 5024 < 0.01 172,316 K 202,640 K SmartAssembly Red Gate Software Ltd.

After one build:

SmartAssembly.exe SmartAssembly.exe 5024 0.01 1,227,888 K 1,055,156 K SmartAssembly Red Gate Software Ltd.

Without closing SA, after second build:

SmartAssembly.exe SmartAssembly.exe 5024 0.02 499,076 K 446,916 K SmartAssembly Red Gate Software Ltd.

What is interesting is when i clicked Build, it immediately died. Clicking retry threw an unhandled exception which i reported via SA (object reference not set to an object). I used my email address on the bug report as well.

SA shut down after i submitted the error.

Let me know if you want anything else from me and i will get it ASAP.

Eric
Eric R Peterson
EricPeterson
 
Posts: 5
Joined: Thu Nov 03, 2011 10:15 pm

Postby Chris.Allen » Mon Dec 05, 2011 2:13 pm

I wonder if we can seperate building smartassembly-protected app from building app (since they are, really, independant). I was also told that If you accidently build the vshost of an app, you get this exception during the build. In other words- let's take visual studio out of the equation just for now...
Chris.Allen
 
Posts: 594
Joined: Thu Mar 12, 2009 4:17 pm

Postby EricPeterson » Mon Dec 05, 2011 4:15 pm

i am only talking about using SA. VS was not even open when i did the test above.

please advise
Eric R Peterson
EricPeterson
 
Posts: 5
Joined: Thu Nov 03, 2011 10:15 pm

Postby Chris.Allen » Fri Dec 09, 2011 1:24 pm

As I say- memory leaking are a known issue- but it sounds like you have a different problem- that of it actually *crashing*. But is it crashing because too much memory has been used?
Can you downgrade to 6.2 and see if it behaves better please:

http://downloads.red-gate.com/checkforu ... .2.215.exe

This, at least, proves its a regression and we will know which part of the code is causing the issue
Chris.Allen
 
Posts: 594
Joined: Thu Mar 12, 2009 4:17 pm


Return to SmartAssembly 6

Who is online

Users browsing this forum: No registered users and 1 guest