result returned by multi script is different from ...

Single-click script execution on multiple SQL Servers.

Moderators: JonathanWatts, Anu Deshpande, dlkj, Colin Millerchip, Michelle Taylor

result returned by multi script is different from ...

Postby ogrishman » Mon Dec 27, 2010 6:12 am

Hi,

I use multi script to run the following script(test whether the sqlbackup is installed on the server):
Code: Select all
DECLARE @result INT;
SELECT @result = ISNULL(OBJECT_ID (N'master..sqlbackup'), 0);
IF @result <> 0
BEGIN
    PRINT 'INSTALLED'
END
ELSE
BEGIN
    PRINT 'NOT INSTALL'
END


multi script returns \"NOT INSTALLED\", so I go to the server for further investigating. When I run the same code on the server directly, the server returns \"INSTALLED\".

Any ideas on why this happens? Thanks.
ogrishman
 
Posts: 29
Joined: Mon Apr 12, 2010 8:21 pm

Postby peter.peart » Tue Dec 28, 2010 2:06 pm

Hi there,

Thanks for your post. We are really going to need some more information unfortunately.

Can you screenshot this happening in Multiscript and ensure that we can see from the screenshot what servers this is being run on, as well as screenshotting the query run in SSMS, along with displaying the instance and DB that you are connected to?

Once that's done, please send it into support(at)red-gate.com with reference F0042734 in the subject line and we will look into it for you.

Many thanks!

Pete
Peter Peart
Red Gate Software Ltd
+44 (0)870 160 0037 ext. 8569
1 866 RED GATE ext. 8569
peter.peart
Site Admin
 
Posts: 362
Joined: Tue Sep 02, 2008 9:58 am
Location: Top floor, RG towers with the cool kids

Postby ogrishman » Wed Dec 29, 2010 2:16 pm

Sorry my fault. The login I use in multi script do not have enough permission. So it gives a \"not installed\" result.

Thanks.
ogrishman
 
Posts: 29
Joined: Mon Apr 12, 2010 8:21 pm


Return to SQL Multi Script 1

Who is online

Users browsing this forum: No registered users and 0 guests