Plugins will not load

Explore, browse and analyze .NET assemblies

Moderators: Luke Jefferson, Clive Tong, nick.maidment

Plugins will not load

Postby JohaViss » Tue Dec 21, 2010 11:24 am

None of the plugins I used with version 6.5 will load. :cry:

No reason why, just the message that the plugins faild to load.

Does Reflector 7 needs updated plugins?
JohaViss
 
Posts: 12
Joined: Thu Oct 23, 2008 11:00 am

Postby Bart Read » Tue Dec 21, 2010 12:27 pm

Hi there,


The short answer is, yes, the plug-ins will need a recompile. We have extended the API in several places. Both Clive and I have tried to be pretty careful, for example, deriving new interfaces rather than changing existing ones, so a recompile isn't strictly necessary, but this obviously doesn't rule out all breaking changes.

As a result we've revved the assembly version number to force a recompile. What this means is that we can be sure that any problems reported really are problems with Reflector, and not with one of the add-ins manifesting some incompatibility with the new version.

We've already started working with the active add-in authors to help ensure that their add-ins are compatible with the new version and, once v7 has stabilised, I fully expect to see compatible add-ins being released early next year.

Hope that helps!


Thanks,


Bart
Bart Read
Principal Consultant
bartread.com Ltd
Bart Read
 
Posts: 977
Joined: Thu Mar 31, 2005 11:17 am
Location: Cambridge, UK

Postby paulo.morgado » Tue Dec 21, 2010 1:25 pm

I'm not sure if it's worth it, but the Managed AddIn Framework can help here (http://blogs.msdn.com/b/sidharth/archive/2009/05/03/working-with-the-managed-addin-framework-system-addin.aspx).
Paulo Morgado
Portugal
Web Site
Weblog
Twitter
paulo.morgado
 
Posts: 52
Joined: Wed Aug 16, 2006 3:41 pm
Location: Portugal


Return to .NET Reflector 7 EAP

Who is online

Users browsing this forum: No registered users and 0 guests