SmartAssembly errors out

.NET obfuscator and automated error reporting

Moderators: Luke Jefferson, Alex.Davies, melvyn.harbour

SmartAssembly errors out

Postby sdm » Wed Oct 20, 2010 11:14 pm

Hi,
I'm running SmartAssembly 5 with MSBuild on my 32bit test server with windows server 2008 on it, and it builds fine. Now when I use same code to run on my 64bit prod server with windows server 2008 R2, my Application errors out. This is the error I get
D:\\Builds\\1\\xyz\\xyz\\xyz.csproj (103): SmartAssembly build failed: The system cannot find the file specified. (Exception from HRESULT: 0x80070002).

Clicking on the above error points me to this line in .csproj file

<Target Name="AfterCompile" Condition=" '$(RunSmartAssembly)' != '' ">
<SmartAssembly.MSBuild.Tasks.Build ProjectFile="..\\Build\\Release.saproj" OverwriteAssembly="True" />
</Target>

I'm sure no file is missing on the server and the ProjectFile has the right path. If we open up the .saproj manually on the server, it builds just fine.

Any help is appreciated.

Thanks
sdm
 
Posts: 3
Joined: Mon Aug 30, 2010 4:04 pm

Postby nick.maidment » Thu Oct 21, 2010 10:09 am

Could you send your .csproj and .saproj files to support @ red-gate . com with F0040439 in the subject line. We'll do what we can to ensure they're correct.

The only other thing you can do is verify that all the files are in the correct locations and that you're building the project in release mode rather than debug mode.
nick.maidment
 
Posts: 74
Joined: Fri Jan 29, 2010 1:55 pm


Return to SmartAssembly 5

Who is online

Users browsing this forum: No registered users and 0 guests