Continually get Exception from HRESULT: 0x8004010F

Email archiving software for Exchange

Moderators: JonathanWatts, richardjm, Robert, Matthew Flatt

Continually get Exception from HRESULT: 0x8004010F

Postby mmillerhta » Fri Sep 24, 2010 9:45 pm

While attempting "Copy back to Exchange" I recieve the below error:

System.Runtime.InteropServices.COMException (0x8004010F): Exception from HRESULT: 0x8004010F
at RedGateMapiLib.AttachmentClass.GetBinaryAttachmentData()
at RedGate.ExchangeArchiver.MAPI.Engine.MapiAttachment.GetNormalDataStream()
at RedGate.ExchangeArchiver.MAPI.Engine.MapiAttachment.CreateMailAttachment()
at RedGate.ExchangeArchiver.MAPI.Engine.MapiMessage.CreateMailItem()
at r.<EnumerateMessages>d__0.MoveNext()
15:10:32.788|Trace |TaskAction |3 |RedGate.ExchangeArchiver.ArchiveService.Interface.ArchiveServiceException: For error details see log files in C:\\Documents and Settings\\All Users\\Application Data\\Application Data\\Red Gate\\Logs\\ESA Archive Service 3 ---> System.Runtime.InteropServices.COMException (0x8004010F): Exception from HRESULT: 0x8004010F
at RedGateMapiLib.AttachmentClass.GetBinaryAttachmentData()
at RedGate.ExchangeArchiver.MAPI.Engine.MapiAttachment.GetNormalDataStream()
at RedGate.ExchangeArchiver.MAPI.Engine.MapiAttachment.CreateMailAttachment()
at RedGate.ExchangeArchiver.MAPI.Engine.MapiMessage.CreateMailItem()
at r.<EnumerateMessages>d__0.MoveNext()
at t.<EnumerateMessages>d__0.MoveNext()
at RedGate.ExchangeArchiver.Exchange.Engine.ExchangeEngine.<GetMessagesFromMailbox>d__0.MoveNext()
--- End of inner exception stack trace ---
at RedGate.ExchangeArchiver.Exchange.Engine.ExchangeEngine.<GetMessagesFromMailbox>d__0.MoveNext()
at v.a(String , T , ScheduleBase , B , TimeoutPending , IExchangeAbstraction , IActiveDirectoryService , M , d , Boolean& )
at v.DoWork()
at RedGate.ExchangeArchiver.ArchiveService.Engine.Tasks.TaskBase.RedGate.ExchangeArchiver.ArchiveService.Engine.Tasks.ITask.Action()
15:10:32.788|Debug |Job Controller |8 |Tasks finished in phase Pullback of scheduleSchedule(No schedule)(id 2).
15:10:32.788|Trace |Archive Service |8 |RedGate.ExchangeArchiver.ArchiveService.Interface.ArchiveServiceException: For error details see log files in C:\\Documents and Settings\\All Users\\Application Data\\Application Data\\Red Gate\\Logs\\ESA Archive Service 3 ---> System.Runtime.InteropServices.COMException (0x8004010F): Exception from HRESULT: 0x8004010F
at RedGateMapiLib.AttachmentClass.GetBinaryAttachmentData()
at RedGate.ExchangeArchiver.MAPI.Engine.MapiAttachment.GetNormalDataStream()
at RedGate.ExchangeArchiver.MAPI.Engine.MapiAttachment.CreateMailAttachment()
at RedGate.ExchangeArchiver.MAPI.Engine.MapiMessage.CreateMailItem()
at r.<EnumerateMessages>d__0.MoveNext()
at t.<EnumerateMessages>d__0.MoveNext()
at RedGate.ExchangeArchiver.Exchange.Engine.ExchangeEngine.<GetMessagesFromMailbox>d__0.MoveNext()
--- End of inner exception stack trace ---
at RedGate.ExchangeArchiver.Exchange.Engine.ExchangeEngine.<GetMessagesFromMailbox>d__0.MoveNext()
at v.a(String , T , ScheduleBase , B , TimeoutPending , IExchangeAbstraction , IActiveDirectoryService , M , d , Boolean& )
at v.DoWork()
at RedGate.ExchangeArchiver.ArchiveService.Engine.Tasks.TaskBase.RedGate.ExchangeArchiver.ArchiveService.Engine.Tasks.ITask.Action()
15:10:32.788|Error |Archive Service |8 |For error details see log files in C:\\Documents and Settings\\All Users\\Application Data\\Application Data\\Red Gate\\Logs\\ESA Archive Service 3
15:10:32.788|Warn |Job Controller |4 |Copy back task has finished. No messages were copied back.
Mailboxes processed: 1

I am currently running:
Exchange 2003 Sp2
ESA 3.0.0.922
MAPI 6.5.8022.0
mmillerhta
 
Posts: 1
Joined: Fri Sep 24, 2010 9:38 pm

Postby Linda Hawksworth » Mon Sep 27, 2010 9:53 am

I think you have encountered a known issue with Exchange Server Archiver. Somehow some of the mail attachments become detached from the mail with no filename.

We have a patch for the copy back issue you are seeing. You can download the patch to the ESA Archive Service from ftp://support.red-gate.com/patches/ESA/ ... 0.1.25.zip

Please confirm that this resolves the issue.
Linda Hawksworth
 
Posts: 192
Joined: Mon Jun 25, 2007 11:32 am


Return to Exchange Server Archiver

Who is online

Users browsing this forum: No registered users and 0 guests