SQL Response service on Alert Repository server is hung

Monitor, diagnose and receive alerts to problems across your SQL Servers.

Moderators: eddie davis, david connell, dlkj, Colin Millerchip, priyasinha, Emma A

SQL Response service on Alert Repository server is hung

Postby digitalaaron » Thu Aug 12, 2010 7:04 am

I have a problem with the SQL Response service currently running on our Alert Repository server. I tried to make a change to the user name and password that is configured in the service properties. After hitting Apply, I got a warning telling me the changes wouldn't go into effect until the service was stopped and restarted. "No problem", I thought, as I hit the OK button. I'm not sure if the restart tried to process right after the OK button, or if I invoked it directly afterward. Either way, a dialog box with a status popped up and it said the service was being stopped and then started. The progress bar went very slowly, and at the end, I got an error saying that the service was unable to be restarted because it had not been stopped.

At that point I went back to the Services window and saw that the status of the service was "Stopping". It's been like that for several hours now, and as you might expect, we have no access to the monitoring.

Normally I would just reboot the server, but this is part of our high-availability, production system, so downtime is out of the question.

Is there a way to manually force the service to stop and restart? The Alert Repository is running on a Windows 2008 R2 machine and is monitoring two SQL 2008 R2 servers.

Any help would be appreciated.
digitalaaron
 
Posts: 2
Joined: Thu Aug 12, 2010 4:58 am

Postby priyasinha » Wed Aug 18, 2010 2:25 pm

Hi,

I would suggest trying looking for RedGate.SqlResponse.AlertRepository.Service.exe process in task manager. If you see any entry for RedGate.SqlResponse.AlertRepository.Service.exe then end this process. After that try restarting the Alert Repository service again.

Thanks,
Priya
priyasinha
 
Posts: 532
Joined: Wed Jan 03, 2007 5:02 pm

Re:

Postby digitalaaron » Wed Aug 18, 2010 4:34 pm

priyasinha wrote:Hi,

I would suggest trying looking for RedGate.SqlResponse.AlertRepository.Service.exe process in task manager. If you see any entry for RedGate.SqlResponse.AlertRepository.Service.exe then end this process. After that try restarting the Alert Repository service again.

Thanks,
Priya


Thank you, Priva. This is actually what I did to fix the problem. Sorry I didn't update this post once I got it working.
digitalaaron
 
Posts: 2
Joined: Thu Aug 12, 2010 4:58 am

Postby priyasinha » Wed Aug 18, 2010 5:11 pm

Glad to know that it is all working for you now.

Regards,
Priya
priyasinha
 
Posts: 532
Joined: Wed Jan 03, 2007 5:02 pm


Return to SQL Response 1

Who is online

Users browsing this forum: No registered users and 0 guests