Abort Compare

Early Access Program for Schema Compare for Oracle

Moderators: David Atkinson, eddie davis, richardjm, alice.easey, Tom Harris

Abort Compare

Postby bobbyinga » Thu Apr 15, 2010 3:05 pm

When trying to compare 2 schemas for the first time, when the software is Registering database one, Populating foreign keys, I receive object reference not set to an instance of an object and the compare halts.

I can change the schemas that I want it to compare but get the same error over and over.

There is no info in the event viewer on this error.

Turned on logging.. Log message reads:

Code: Select all

10:10:45.976|Error  |Engine Service      |1  |:Exception in progress dialog
System.NullReferenceException: Object reference not set to an instance of an object.
   at RedGate.Oracle.ObjectModel.DatabaseFactory.p()
   at RedGate.Oracle.ObjectModel.DatabaseFactory.Populate()
   at RedGate.Oracle.ObjectModel.LivePopulator.Populate()
   at RedGate.Oracle.ObjectModel.DatabasePopulationHelper.a(IPopulator , ICollection`1 )
   at RedGate.Oracle.ObjectModel.DatabasePopulationHelper.PopulateDatabase1()
   at RedGate.Shared.Controls.ProgressDialogEx.e()
[/code]
bobbyinga
 
Posts: 1
Joined: Thu Apr 15, 2010 2:58 pm

Postby Simon C » Fri Apr 16, 2010 9:51 am

Sorry it's not working for you... Would it be possible to send me (email link at bottom of this post) a query snapshot of the two databases? This can be obtained using the RedGate.Oracle.CreateQuerySnapshot program in the SCfO install directory. This contains the raw data that we read from the database & only contains schema information, and this'll help us find out what's going on very quickly
Simon C
 
Posts: 140
Joined: Tue Feb 26, 2008 4:56 pm
Location: Red Gate Software


Return to Schema Compare for Oracle Beta

Who is online

Users browsing this forum: No registered users and 0 guests