Cookie problem

Forum for users of ANTS web server load testing tool

Moderator: Brian Donahue

Cookie problem

Postby slaneyrw » Mon May 01, 2006 11:10 pm

Hi

I am evaluating the ANTS Load product, and I am having problems with cookies.

A simple script requests a homepage, submits a username/password and then logs out.

The login page redirects

If I record a script based from the browser, it gets all 4 pages
( index.aspx, login.aspx, myaccount.aspx, logout.aspx ), including the redirect from login.aspx to myaccount.aspx.

If I replay the script, then call to myaccount.aspx returns a 302 instead of 200, beause the user is not logged in, as the cookie information is not returned.

I have manually inspected the request object in the aspx page to verify this.

I checked out the article on the viewstate/cookie here in the knowledgebase, and I dumped the header information to Me.LogToFile. the Set-Cookie header IS returned as expected from each step.

I have tried clearing the CookieContainter at the start of each run, and also built the cookie collection manually (from the set-cookie header) after each page request, to no avail.

I don't know what to try next. Any help will be appreciated, but if I can't work this out, the product will be of no use.
slaneyrw
 
Posts: 28
Joined: Tue Feb 08, 2005 10:01 pm

Postby Brian Donahue » Mon May 08, 2006 7:04 pm

Hello,

Sorry, I don't know what it could be. Maybe if you post up the script and point out the place where the redirect happens?
Brian Donahue
 
Posts: 6668
Joined: Mon Aug 23, 2004 10:48 am


Return to ANTS Load

Who is online

Users browsing this forum: No registered users and 0 guests